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"Unable to complete the operation on <event log>. Access is denied." error message when you try to access a log on a Windows Server 2003-based computer


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Symptoms

When you try to access the Application log, the System log, the directory service log, the DNS server log, or the file replication service log on a Microsoft Windows Server 2003-based computer, you may receive an error message that is similar to the following:
Unable to complete the operation on event log. Access is denied.

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Cause

This problem occurs if the Domain Users group is a member of the built-in Guests group. By default, the built-in Guests group does not have access to the event logs.

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Resolution

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

If your computer is a domain controller, follow these steps to resolve this problem:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Active Directory Users and Computers.
  2. In the left pane, expand the domain name, and then click Builtin.
  3. In the right pane, double-click Guests, and then click the Members tab.
  4. In the Members list, click Domain Users, click Remove, click Yes, and then click OK.
If your computer is not a domain controller, follow these steps to resolve this problem:
  1. Click Start, click Run, type regedit, and then click OK.
  2. In the left pane, expand HKEY_LOCAL_MACHINE, expand SYSTEM, expand CurrentControlSet, expand Services, expand Eventlog, and then click Application.
  3. In the right pane, double-click RestrictGuestAccess, type 0 in the Value data box, and then click OK.
  4. In the left pane, click DNS Server under
    Eventlog
    .
  5. In the right pane, double-click RestrictGuestAccess, type 0 in the Value data box, and then click OK.
  6. In the left pane, click System under
    Eventlog
    .
  7. In the right pane, double-click RestrictGuestAccess, type 0 in the Value data box, and then click OK.
  8. Quit Registry Editor.
  9. Restart your computer.

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Keywords: KB888189, kbtshoot

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Article Info
Article ID : 888189
Revision : 3
Created on : 10/30/2006
Published on : 10/30/2006
Exists online : False
Views : 296