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The domain name may not appear in its correct form in the DNS record of a Windows 2000-based or Windows Server 2003-based domain controller


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Symptoms

When you use a Microsoft Windows 2000 Server-based or Microsoft Windows Server 2003-based domain controller, some services of the Active Directory directory service, such as Lightweight Directory Access Protocol (LDAP) services, may not function correctly. When you try to troubleshoot the domain controller, you may also experience the following symptoms:
  • When you examine the Netlogon.dns file, you see text entries that display only the host name of the domain controller and not the fully qualified domain name (FQDN).
  • When you run the Dcdiag.exe command-line tool at the command prompt, the output indicates that the FQDN of the domain controller could not be resolved.
  • When you use the DNS snap-in to examine the DNS record in the _msdcs DNS zone, the FQDN of the domain controller appears as ServerName, where ServerName is the name of the Windows DNS server.
  • When you restart the domain controller, the Windows Server 2003 operating system recognizes the domain controller as a host that does not have a domain name. For example, if the FQDN of the domain controller is host.domain.com, the operating system recognizes only the host name ("host") and not the domain name ("domain.com").
  • When the DNS service is started, the following event is recorded in the DNS server event log:
  • When you try to restart the Exchange System Attendant service on a computer that is running Microsoft Exchange 2000 Server, the service does not start.

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Cause

This issue may occur because of a corrupted registry entry in the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
One of more of the following registry entries in this registry subkey may be corrupted:
  • Domain
  • Hostname
  • NV Domain
  • NV Hostname
If Active Directory Service Location (SRV) resource records refer to the incorrect domain name, the domain controller cannot resolve the domain name. Because of this, Active Directory services may not work correctly.

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Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


To resolve this issue, use Registry Editor to remove and re-create the registry entries that are mentioned in the "Cause" section. To do this, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. In Registry Editor, locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. In the right pane, right-click Domain, and then click Delete.
  4. When you are prompted to confirm the deletion, click Yes.
  5. Repeat steps 3 and 4 for the Hostname, NV Domain, and NV Hostname registry entries.
  6. On the Edit menu, point to New, and then click String Value.
  7. Type Domain, and then double-click Domain.
  8. In the Value data box, type the Active Directory domain name, and then click OK. For example, you may type contoso.com as the domain name.
  9. Repeat steps 6 through 8 for the NV Domain registry entry.
  10. On the Edit menu, point to New, and then click String Value.
  11. Type Hostname, and then double-click Hostname.
  12. In the Value data box, type the computer name, and then click OK.
  13. Repeat steps 10 through 12 for the NV Hostname registry value.
  14. Quit Registry Editor.
  15. Click Start, click Run, type services.msc in the Open box, and then click OK.
  16. In the right pane of the Services window, locate and then click Net Logon.
  17. On the Action menu, click Stop.
  18. On the Action menu, click Start.

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More Information

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

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Keywords: kb, kbtshoot, kbentirenet, kbwinservnetwork

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Article Info
Article ID : 888048
Revision : 9
Created on : 8/20/2020
Published on : 8/20/2020
Exists online : False
Views : 491