Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The TCP session does not close until you run the "net session /d" command to delete the SMB session on the file server on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer, you open files from the network. These files are still locked after you log off the client computer. If you examine the Transmission Control Protocol (TCP) sessions by using the netstat command, you see a TCP session that is similar to the following:
File server:  
 
  TCP    xxx.xxx.xxx.xxx:445     xxx.xxx.xxx.xxx:3572    CLOSE_WAIT
 
Client:
 
  TCP    xxx.xxx.xxx.xxx:3572    xxx.xxx.xxx.xxx:445     FIN_WAIT_2
The TCP session does not close until you run the net session /d command to delete the Server Message Block (SMB) session on the file server.

↑ Back to the top


Cause

This issue occurs because of a problem in the Tcpip.sys file. This problem causes the TCP session to remain open.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Feb-2005  00:45  5.2.3790.280      336,896  Tcpip.sys
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Feb-2005  08:39  5.2.3790.280      977,920  Tcpip.sys

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was corrected in Microsoft Windows Server 2003 Service Pack 1.

↑ Back to the top


References

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
137984� TCP Connection States and Netstat Output

↑ Back to the top


Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbbug, kbfix, kbwinserv2003presp1fix, KB887707

↑ Back to the top

Article Info
Article ID : 887707
Revision : 2
Created on : 9/11/2011
Published on : 9/11/2011
Exists online : False
Views : 300