Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Pop-up window closes unexpectedly during a download in Internet Explorer 6


View products that this article applies to.

Symptoms

After you install Microsoft Windows XP Service Pack 2 (SP2) or you install Microsoft Windows Server 2003 Service Pack 1 (SP1), you may experience the following problem in Microsoft Internet Explorer 6.

You open a Web page that has a hidden iframe. Then you click a button that sets the source of the hidden iframe to an ASP page that initiates a file download with the Content-Disposition set to attachment. In the File Download dialog box, when you click any one of the following buttons, the file download is opened, saved, or canceled correctly:
  • Open
  • Save
  • Cancel
However, the window with the iframe that initiated the download closes. This window did not close before Windows XP SP2 or Windows Server 2003 SP1 was installed.

Additionally, you may experience this problem if you are using a frameset that has a simple link to a download URL from a page in the frameset.

This problem occurs only when the page that has the hidden iframe or the frameset was opened by using the window.open method.

↑ Back to the top


Cause

Microsoft is researching this problem and will post more information in this article when the information becomes available.

↑ Back to the top


Workaround

To work around this problem, initiate the content with window.open instead of inside the iframe on the Web page. To do this, use the following sample script as an example.

Microsoft provides programming examples for illustration only, without warranty either expressed or implied, including, but not limited to, the implied warranties of merchantability and/or fitness for a particular purpose. This article assumes that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures. Microsoft support professionals can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific needs.
If you have limited programming experience, you may want to contact a Microsoft Certified Partner or Microsoft Advisory Services. For more information, visit these Microsoft Web sites:

Microsoft Certified Partners - https://partner.microsoft.com/global/30000104

Microsoft Advisory Services - http://support.microsoft.com/gp/advisoryservice

For more information about the support options that are available and about how to contact Microsoft, visit the following Microsoft Web site:http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMSYou can use the following code to determine whether your computer is running Windows XP SP2.
<SCRIPT>
var bIsXP=false;
var bIsXPSP2=false;
window.onload=fnInit;

function fnInit()
{
   if(navigator.userAgent.indexOf("Windows NT 5.1")>-1)
   {
      bIsXP=true;
   }

   if(bIsXP==true)
   {
      if(navigator.userAgent.indexOf("SV1")>-1)
      {
        bIsXPSP2 = true;
      }
   }

   alert(bIsXPSP2);

   if (bIsXPSP2)
   {
      //do the special code, basically, redirect to the XPSP2 page
      window.location = "page_xpsp2.htm";
   }
}
</SCRIPT>

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB887301, kbprb, kbtshoot

↑ Back to the top

Article Info
Article ID : 887301
Revision : 11
Created on : 8/13/2007
Published on : 8/13/2007
Exists online : False
Views : 460