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Shared disks are missing or are marked as "Failed" when you create a server cluster in Windows Server 2003


View products that this article applies to.

Symptoms

When you configure a new server cluster on a computer that is running Microsoft Windows Server 2003, you may experience the following symptoms:
  • A warning icon may appear next to Checking cluster feasibility on the Analyzing Configuration page of the New Server Cluster Wizard.
  • The New Server Cluster Wizard may configure the cluster to use a Local Quorum resource instead of an existing shared hard disk. In this scenario, if you click View Log on the Analyzing Configuration page of the New Server Cluster Wizard, you may notice information that is similar to the following:
    Date and Time [INFO] <ClusterName>: Checking that all nodes have access to the quorum resource... (hr=00000000, {GUID}, {GUID}, 0, 2, 0), (NULL)
    Date and Time [WARN] <ClusterName>: Could not locate a sharable quorum resource and a local quorum cluster will be created. (hr=0x0713de, {GUID}, {GUID}, 1, 1, 1), (NULL)
  • After you configure the cluster, some shared hard disks may be missing. In this scenario, if you view the information that appears on the Proposed Cluster Configuration page of the New Server Cluster Wizard, you notice that some existing shared hard disks do not appear under Resource configuration.
  • After you configure the cluster, some shared hard disks may be marked as "Failed."

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Cause

This problem may occur if the Windows Server 2003-based computer contains more than one host bus adapter (HBA) controller. This problem occurs because the cluster Setup program does not examine the full storage path of the storage devices on your computer.

Instead of using the Port:Bus:Target:logical unit number (LUN) addressing scheme to address a specific storage device, the New Server Cluster Wizard references only the Target:LUN of a device to address a specific device. Therefore, if you have more than one HBA controller in the computer, the Target:LUNs may be duplicated. This duplication may cause the cluster configuration to fail, or it may cause one or more of the symptoms that are described in the "Symptoms" section.

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Resolution

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

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Workaround

To work around this problem, specify a minimum configuration in the New Server Cluster Wizard. This action turns off the storage device detection that occurs during the analysis of the cluster configuration. Therefore, the New Server Cluster Wizard can finish successfully. To specify a minimum configuration, follow these steps:
  1. Start the Cluster Administrator tool. To do this, click Start, point to Administrative Tools, and then click Cluster Administrator.
  2. In the Open Connection to Cluster dialog box, click Create new cluster in the Action list, and then click OK.
  3. In the New Server Cluster Wizard, click Next.
  4. Verify that the correct domain appears in the Domain list, type a name for the new cluster in the Cluster name box, and then click Next.
  5. On the Select Computer page, type the name of the first cluster node in the Computer name box, and then click Advanced.
  6. Click Advanced (minimum) configuration, and then click OK.
  7. Click Next.
  8. When the New Server Cluster Wizard has finished the determination of the cluster configuration, click Next.
  9. In the IP Address box, type the IP address of the server cluster, and then click Next.
  10. On the Cluster Service Account page, type the user name and the password of your cluster service account, and then click Next.
  11. View the information that appears on the Proposed Cluster Configuration page, and then click Next.
  12. When the server cluster is configured successfully, click Next, and then click Finish.
Note After you configure the server cluster by using the Advanced (minimum) configuration option, the server cluster is configured to use either a Local Quorum resource or a Majority Node Set for the quorum resource. In this scenario, you must manually add the physical disk resources to the cluster, and then move the quorum to a shared physical disk.

For more information about how to change the quorum on a server cluster, click the following article numbers to view the articles in the Microsoft Knowledge Base:
259267� Microsoft Cluster Service installation resources
280353� How to change the quorum disk designation
For additional information about how to configure a server cluster, see the Help file.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 1.

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More information

For more information about a similar problem, click the following article number to view the article in the Microsoft Knowledge Base:
331801� Cluster Setup may not work when you add nodes

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Keywords: KB886807, kbprb, kbtshoot, kbclustering

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Article Info
Article ID : 886807
Revision : 4
Created on : 11/14/2005
Published on : 11/14/2005
Exists online : False
Views : 340