Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an HTTP_500 error message when you synchronize your mobile device with Microsoft Exchange Server 2003


View products that this article applies to.

Symptoms

When you synchronize your mobile device with Microsoft Exchange Server 2003, you receive the following error message:
Error code: HTTP_500

Synchronization failed due to an error on the server. Try again.

↑ Back to the top


Cause

Exchange ActiveSync typically locates the mailbox by using the left-hand side (LHS) of the primary Simple Mail Transfer Protocol (SMTP) address. The problem that is described in the Symptoms section occurs if the following conditions are true:
  • The user has multiple SMTP addresses.
  • The primary SMTP address does not match the default Recipient Policy.

↑ Back to the top


Resolution

To resolve this issue, install Microsoft Exchange Server 2003 Service Pack 2 (SP2). If applying Exchange Server 2003 SP2 is not an option, add a registry key to force Exchange ActiveSync to locate the mailbox by using the secondary SMTP addresses. To do this, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


Note This change requires that you restart the Microsoft Internet Information Services (IIS) Admin service.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key:
    HKEY_Local_Machine\System\CurrentControlSet\Services\MasSync\Parameters\
  3. Right-click Parameters, click New, and then click String Value.
  4. "New value #1" is selected. Type SMTPProxy and then press ENTER to rename the value. Right-click SMTPProxy, and then click Modify.
  5. In the String Data line, type the SMTP domain of your default Recipient Policy. For example, type contosoltd.com.
  6. Click OK to quit Registry Editor.
  7. Restart the IIS Admin service. To do this, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. In the list of services, right-click IIS Admin service, and then click Restart.
After you apply the new registry setting, Exchange ActiveSync will look through all the SMTP addresses to locate the mailbox. For example, a user at Contoso, Ltd. has the following SMTP configuration:
SMTP:admin@contoso.com <------------Primary SMTP address
smtp:admin@contosoltd.com
After you add the SMTPProxy value and set it to contosoltd.com, Exchange ActiveSync will correctly look for the admin@contosoltd.com mailbox.

Important
  • Make sure that the back-end mailbox server is running a version of Exchange Server that is later than Microsoft Exchange Server 2003 Service Pack 1 (build 6.5.7226).
  • For this resolution to work, on the Exchange servers, you must disable the
    DisableSMTPMailboxAddressing
    registry entry, if it exists. To turn off this registry entry, set the value of the following registry entry to 0:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeWEB\OWA\DisableSMTPMailboxAddressing

↑ Back to the top


Keywords: KB886346, kbprb

↑ Back to the top

Article Info
Article ID : 886346
Revision : 12
Created on : 11/29/2007
Published on : 11/29/2007
Exists online : False
Views : 338