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FIX: You receive an "Access is denied" error message when you open a Web page that runs a script in a frameset in Internet Explorer 6


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

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Symptoms

In Microsoft Internet Explorer 6, you open a Web page that contains a frameset. If a script runs in the left frame of the frameset, you receive the following error message:
Problems with this Web page might prevent it from being displayed properly or functioning properly. In the future, you can display this message by double-clicking the warning icon displayed in the status bar.

Line: 6
Char: 2
Error: Access is denied.
Code: 0
URL: http://URLPath/frameset.html

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Cause

This problem may occur when the following conditions are true:
  • The Document.Domain property is explicitly defined in a cross-frame script. For example, microsoft.com.
  • One of the following conditions is true:
    • You have Microsoft Windows XP Service Pack 2 (SP2) installed.
    • You have Internet Explorer 6 Service Pack 1 (SP1) installed and then you install the cumulative security update for Internet Explorer (MS04-025).

      For additional information about the cumulative security update for Internet Explorer (MS04-025), click the following article number to view the article in the Microsoft Knowledge Base:
      867801� MS04-025: Cumulative security update for Internet Explorer

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft Internet Explorer 6 SP1 installed to apply this hotfix. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
328548� How to obtain the latest service pack for Internet Explorer 6

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any later hotfix.

Registry information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To enable this hotfix, follow these steps:
  1. Quit Internet Explorer 6.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
  4. On the Edit menu, point to New, and then click Key.
  5. Type FeatureControl, and then press ENTER.
  6. With the FeatureControl subkey selected, point to New on the Edit menu, and then click Key.
  7. Type FEATURE_DOC_WRITE_DOMAIN_KB886184, and then press ENTER.
  8. With the FEATURE_DOC_WRITE_DOMAIN_KB886184 subkey selected, point to New on the Edit menu, and then click DWORD Value.
  9. Type Iexplore.exe, and then press ENTER.
  10. Right-click Iexplore.exe, and then click Modify.
  11. In the Value data box, type 1, and then click OK.
  12. On the File menu, click Exit to quit Registry Editor.

Hotfix file information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ---------------------------------------------------------
   09-Feb-2005  01:36  6.00.2800.1493  2,699,776  Mshtml.dll 				

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Status

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6 Service Pack 1.

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More information

For more information about the Document.Domain property, visit the following Microsoft Web site:

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Keywords: KB886184, kbhotfixserver, kbqfe, kbbug, kbfix, kbie600presp2fix, kbautohotfix

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Article Info
Article ID : 886184
Revision : 8
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 295