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EFI boot manager entries are reordered when you deploy a Windows Server 2003 image that you created by using the Sysprep tool and an imaging solution


View products that this article applies to.

Symptoms

You are using the Microsoft System Preparation tool (Sysprep) and an imaging solution to image a computer that is running Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems. When you deploy the image to a computer, the Extensible Firmware Interface (EFI) boot manager options are reordered. For example, this problem occurs when you follow these steps:
  1. You set the boot order options in Non-Volatile Random Access Memory (NVRAM) to the following:
    PXE1
    2003
    PXE2
    EFI Shell
  2. You run the Sysprep tool.
  3. You deploy the image.
In this example, the boot order is reordered to the following on the computer that you deployed the image to:
PXE1
PXE2
EFI Shell
2003
Additionally, if Pre-Boot Execution Environment (PXE) startup fails, the computer stops at the EFI shell for keyboard input instead of starting Windows Server 2003.

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Cause

This problem occurs because the Setupcl.exe file changes the partition GUIDs on GUID partition table (GPT) disks. The NVRAM boot entry for Windows is no longer valid because it points to the old GUID. Therefore, the Setupcl.exe file deletes this entry and re-creates it at the end of the boot order list.

Note The Setupcl.exe file is a Sysprep component that regenerates new security identifiers (SIDs) for the computer.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Oct-2004  01:50  5.2.3790.228       79,360  Setupcl.exe  
   

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about boot options in EFI NVRAM, visit the following Microsoft Web site:For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB885891, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 885891
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 380