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A 35-second delay occurs when you delete a file that is located on a network share in Windows Server 2003


View products that this article applies to.

Symptoms

When you use Windows Explorer on a Microsoft Windows Server 2003-based client computer to delete a file that is located on a network share, you experience a delay of approximately 35 to 40 seconds before the file is deleted.

A network trace of the problem shows the following error message for the server message block (SMB) Delete request:
Delete file - NT Error, System Error, Code= (67) STATUS_SHARING_VIOLATION

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Cause

This problem is caused by a pseudo-deadlock condition that exists when the opportunistic lock (oplock) Break request is received by the client computer. When the client computer receives the Break request, it cannot process the request because it is already waiting on the Delete request. The server cannot process the Delete request until the oplock on the file is released. The pseudo-deadlock condition exists until the time-out value that is set in the OplockBreakWait registry entry on the server expires. By default, the OplockBreakWait time-out value is set to 35 seconds.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the hotfix that is documented in the following article in the Microsoft Knowledge Base:
811492 It may take 35 seconds to delete files over the network

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

   Date         Time   Version       Size     File name
   -----------------------------------------------------
   13-Sep-2004  19:19  5.2.3790.210  395,264  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194  158,208  Rdbss.sys

Windows Server 2003, 64-bit editions

   Date         Time   Version       Size       File name
   -------------------------------------------------------
   13-Sep-2004  19:18  5.2.3790.210  1,123,328  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194    464,896  Rdbss.sys

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Workaround

To work around this problem, disable opportunistic locking on either the Windows Server 2003-based client computer or the server where the network share is located. For additional information about how to disable opportunistic locking, click the following article number to view the article in the Microsoft Knowledge Base:
296264 Configuring opportunistic locking in Windows

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies To" section.

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More information

For additional information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB885451

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Article Info
Article ID : 885451
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 352