Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Connection reset by peer" error message when you try to upload a large file to an FTP server that is published through Internet Security and Acceleration Server 2000


View products that this article applies to.

Symptoms

When you try to upload a large file to a File Transfer Protocol (FTP) server that is published through a Microsoft Internet Security and Acceleration (ISA) Server 2000 computer, the transfer unexpectedly quits after 60 seconds. Additionally, you receive the following error message:
Connection reset by peer.

↑ Back to the top


Cause

This problem occurs if the following conditions are true:
  • The ISA Server 2000 computer is configured to replace the source address of incoming requests with the source address of the ISA Server 2000 computer. Therefore, the packets that are sent to the published FTP server have the source address of the ISA Server 2000 computer. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
    311777 How to enable translating client source address in server publishing
  • The Enable IP routing check box is selected on the ISA Server 2000 computer. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
    279347 Enable IP routing on ISA Server to increase performance
In this scenario, the timer is supposed to close the internal FTP secondary connection if the connection is idle for 60 seconds. Instead, the timer incorrectly closes the active secondary connections.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have ISA Server 2000 Service Pack 2 installed. For additional information about how to obtain ISA Server 2000 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Restart requirement

You do not have to restart your computer to install this hotfix. However, the hotfix package will restart all ISA Server services during the installation of this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size      File name 
   --------------------------------------------------------
   28-Sep-2004  09:43   3.0.1200.407   307,192   Wspsrv.exe				

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

After you install this hotfix, the timer operation is canceled if the secondary connection is used within 60 seconds.

For additional information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB885420, kbhotfixserver, kbbug, kbfix, kbftp, kbfirewall, kbautohotfix

↑ Back to the top

Article Info
Article ID : 885420
Revision : 8
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 277