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A rectangle that you draw by using the ExtTexOut function is not displayed after you copy it to a program that uses the Windows metafile format in Windows Server 2003, in Windows XP, and in Windows 2000


View products that this article applies to.

Symptoms

When you try to copy an enhanced metafile (EMF) image into a document in a program that uses the Windows metafile (WMF) format, the image may not be copied into the document. You experience this symptom if the following conditions are true:
  • You run a custom program that uses the ExtTextOut function on a Microsoft Windows Server 2003-based, Windows XP-based, or Windows 2000-based computer.
  • You use the ExtTextOut function to draw a rectangle.
  • You copy the EMF image from the custom program and paste it into a document in a program that uses the WMF format, such as Microsoft Word 2000 or Microsoft Paint.

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Cause

This problem occurs if the following conditions are true:
  • The security update that is described in Microsoft Security Bulletin MS04-011 is installed on your computer. For more information about this security update, visit the following Microsoft Web site:
  • You use the ExtTextOut function with an empty string to draw the rectangle.
The security update that is described in Microsoft Security Bulletin MS04-011 enforces more stringent checks on the validation of metafiles and of the records that they contain.

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Resolution

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions
Date         Time   Version       Size    File name
----------------------------------------------------
05-Oct-2004  21:14  5.2.3790.220  38,400  Mf3216.dll 
Windows Server 2003, 64-bit editions
Date         Time   Version       Size     File name    Platform
----------------------------------------------------------------
05-Oct-2004  22:09  5.2.3790.220  121,344  Mf3216.dll   IA-64
05-Oct-2004  22:14  5.2.3790.220   38,400  Wmf3216.dll  x86

Windows XP

Service Pack information

To resolve this problem, install the latest Windows XP service pack. For additional information about how to obtain the latest service pack for Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, 32-bit editions
Date         Time   Version        Size     File name
-----------------------------------------------------
07-Oct-2004  01:44  5.1.2600.1592  267,776  Gdi32.dll        
07-Oct-2004  01:44  5.1.2600.1596   36,864  Mf3216.dll
Windows XP, 64-bit edition
Date         Time   Version        Size     File name    Platform
-----------------------------------------------------------------
07-Oct-2004  02:40  5.1.2600.1592  885,248  Gdi32.dll    IA-64
07-Oct-2004  02:40  5.1.2600.1596  128,512  Mf3216.dll   IA-64
07-Oct-2004  02:44  5.1.2600.1592  237,568  Wgdi32.dll     x86
07-Oct-2004  02:44  5.1.2600.1596   36,864  Wmf3216.dll    x86

Windows 2000

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
This hotfix requires Windows 2000 Service Pack 4 (SP4).
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version        Size     File name
------------------------------------------------------
29-Aug-2004  05:49  5.0.2195.6972  231,696  Gdi32.dll        
29-Aug-2004  05:49  5.0.2195.6972   37,136  Mf3216.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about the MS04-011: Security Update for Microsoft Windows, click the following article number to view the article in the Microsoft Knowledge Base:
835732 MS04-011: Security Update for Microsoft Windows
For additional information about the ExtTextOut function, visit the following Microsoft Web site: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwin2000presp5fix, kbwinxppresp2fix, kbbug, kbfix, kbwinserv2003presp1fix, KB884865

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Article Info
Article ID : 884865
Revision : 4
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 363