Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft Exchange Information Store service may unexpectedly quit on an Exchange 2000 computer


View products that this article applies to.

Symptoms

The Microsoft Exchange Information Store service (Store.exe) may unexpectedly quit. You do not receive an error message, no events or log entries are recorded, and you do not receive any other indicator of a problem.

↑ Back to the top


Cause

This problem occurs when a stack overflow occurs on your Microsoft Exchange 2000 Server computer.

A stack is the memory space that each thread of a process uses to operate. A stack overflow occurs when a routine overwrites a part of the stack memory address that the routine does not allocate or own. This situation then causes problems for other routines. If the stack becomes large, insufficient memory may be reserved, and the operating system is therefore not able to handle these stack overflows correctly. The stack overflow that triggers the symptom that is described in this article may be caused by a third-party program.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version         Size       File name
--------------------------------------------------------------  
22-Oct-2004  07:54  6.0.6617.17     2,310,144  Mdbmsg.dll       
22-Oct-2004  08:50  6.0.6617.17     4,689,920  Store.exe
Component: MDB

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB884860, kbbug, kbexchange2000presp4fix, kbfix, kbhotfixserver, kbqfe

↑ Back to the top

Article Info
Article ID : 884860
Revision : 5
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 219