Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

HTML e-mail messages lose their formatting when you use the Exchange Mailbox Merge program to migrate .pst files to Exchange Server 2003 mailboxes


View products that this article applies to.

Symptoms

When you use the Microsoft Exchange Mailbox Merge program (Exmerge.exe) to migrate Microsoft Outlook Personal Folders (.pst) files to mailboxes on your Microsoft Exchange Server 2003 computer, many of the HTML e-mail messages lose their HTML formatting during the migration process. For example, when you view the e-mail messages in your Exchange 2003 mailbox, the message text is rendered in plain text format.

↑ Back to the top


Cause

This problem occurs because the Exchange 2003 version of the Mapi32.dll file incorrectly copies the body HTML property as a string instead of as a binary property.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must be running Exchange Server 2003 Service Pack 1 (SP1). For additional information about how to obtain Exchange Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer to install this hotfix. However, the following Exchange services are automatically restarted during the hotfix installation:
  • Microsoft Exchange Site Replication Service
  • Microsoft Exchange Management
  • Microsoft Exchange MTA Stacks
  • Microsoft Exchange Event
  • Microsoft Exchange Information Store
  • Microsoft Exchange System Attendant

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   29-Sep-2004  18:19  6.5.7232.39       635,392  Mapi32.dll    

↑ Back to the top


Workaround

To work around this problem, import the .pst file directly into Outlook by using the Outlook client program.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information about Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbcoexistmigration, kbexchange2003presp2fix, kbfix, kbbug, kbautohotfix, KB884849

↑ Back to the top

Article Info
Article ID : 884849
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 332