Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may receive the "Enterprise single sign-on" Error event message when you create Adapter HTTP Configuration Store entries in BizTalk Server 2004


View products that this article applies to.

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When the Configuration Wizard for Microsoft BizTalk Server 2004 tries to create Adapter HTTP Configuration Store entries, you receive Error event messages and Warning event messages. This problem occurs on a Microsoft Windows XP Service Pack 2-based computer. The Error event messages and the Warning event messages are similar to the following. You receive these in the event log.

Event Type: Error Event
Source: ENTSSO
Event Category: Enterprise Single Sign-On
Event ID: 10514
Date: 5/14/2004
Time: 6:39:36 PM
User: N/A
Computer: <some computer>
Description:
An error occurred while attempting to access the SSO database.
Function: FieldInfoCreate
File: adminserver.cpp:1647
-.
SQL Error code: 0x00000000 Error code: 0x80131509

Event Type: Warning
Event Source: ENTSSO
Event Category: Enterprise Single Sign-On
Event ID: 10536
Date: 5/14/2004
Time: 6:39:36 PM
User: N/A
Computer: <some computer>
Description:
SSO AUDIT
Function: CreateFieldInfo
Tracking ID: 6210bda5-8806-4766-b0bd-dfca8ec07589
Client Computer: <some client computer>
Client User: <some client>
Application Name: {B3629224-0EE0-4125-9805-F15EDF528138}
Error Code: 0x80131509

↑ Back to the top


Cause

This problem occurs if the following registry key is not enabled:
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Rpc\EnableAuthEpResolution

↑ Back to the top


Resolution

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To resolve this problem, do any one of the following:
  • Modify and enable the HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Rpc\EnableAuthEpResolution registry subkey. To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Rpc\EnableAuthEpResolution
    3. On the Edit menu, click Modify.
    4. In the Value data box, type the number 1, and then click OK.
    5. On the File menu, click Exit to close the Registry Editor window.
  • Modify the Group Policy and enable RPC Endpoint Mapper Client Authentication. To do this, follow these steps:
    1. Click Start, click Run, type gpedit.msc, and then click OK.
    2. Expand the following nodes:
      • Computer Configuration
      • Administrative Templates
      • System
    3. Click Remote Procedure Call, and then double�click RPC Endpoint Mapper Client Authentication in the right pane.
    4. In the Endpoint Mapper Client Authentication Properties dialog box, click Enabled, and then click OK.
    5. On the File menu, click Exit to close the Group Policy console.
  • Modify the Microsoft Distributed Transaction Coordinator (MSDTC) settings. To do this, follow these steps:
    1. Click Start, click Run, type dcomcnfg.exe, and then click OK.
    2. Expand the following nodes:
      • Computers Services
      • Computers
    3. Right-click My Computer, and then click Properties.
    4. In the My Computer Properties dialog box, click the MSDTC tab, and then click Security Configuration.
    5. In the Security Configuration dialog box, click to select the Network DTC Access check box under Security Settings.
    6. Under Transaction Manager Communication, click to select the Allow Inbound check box and the Allow Outbound check box, and then click No Authentication Required.
    7. Click OK two times, and then close the Group Policy console.

↑ Back to the top


References

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
841893 � The Enterprise Single Sign-On Service and associated BizTalk Server 2004 services fail after you install Windows XP Service Pack 2

↑ Back to the top


Keywords: KB884623, kbprb, kbbtssso, kbsetup, kbtshoot

↑ Back to the top

Article Info
Article ID : 884623
Revision : 2
Created on : 10/7/2004
Published on : 10/7/2004
Exists online : False
Views : 570