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"Device Status Page Error" error message when your printer tries to display a status notification message


View products that this article applies to.

Symptoms

When your printer tries to display a status notification message, you may receive the following error message:
Device Status Page Error
We are unable to generate the device status page for the selected printer. Please contact your system administrator for more information.
For example, if the printer is out of paper, is out of toner, is jammed, or is offline, you may receive this error message.

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Cause

This problem may occur when Microsoft Windows Server 2003 cannot process status data that is related to a 2-byte hrPrinterDetectedErrorState object value.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit versions
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   06-Oct-2004  17:38  5.2.3790.220       99,328  Oleprn.dll  
Windows Server 2003 64-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   06-Oct-2004  18:38  5.2.3790.220      271,872  Oleprn.dll       IA-64
   06-Oct-2004  18:38  5.2.3790.220       99,328  Woleprn.dll      x86  

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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For more information about the hrPrinterDetectedErrorState object value, visit the following Network Working Group Web site:

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB884552

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Article Info
Article ID : 884552
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 366