Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft Exchange Information Store service quits after a version conflict is detected in a public folder post in Exchange Server 2003


View products that this article applies to.

Symptoms

On your Microsoft Exchange Server 2003 computer, the Microsoft Exchange Information Store service may quit unexpectedly. You may experience this problem soon after a version conflict is detected in a public folder post.

↑ Back to the top


Cause

This problem occurs because of heap corruption in Exchange. This problem may occur if the following conditions are true:
  • The Exchange diagnostics logging level is set to 5 on the MSExchangeIS\Public Folders\Replication Conflicts object.
  • Exchange detects a version conflict in a public folder post. However, only one change number is associated with this version conflict.
This problem occurs in the Exchange event logging code. In this scenario, the event logging code incorrectly expects two change numbers to be involved in every version conflict. If only one change number is involved in a version conflict, the heap becomes corrupted. Soon after the heap becomes corrupted, the Microsoft Exchange Information Store service may quit.

Typically, a version conflict does involve two change numbers. Each of these two change numbers corresponds to an uncommitted change to the information store. However, in the following sample scenario, only one change number is involved in a version conflict:
  1. Two Microsoft Outlook users modify the same message. However, one Outlook user modifies this message while the user is connected to the Exchange computer. The second Outlook user modifies this message while the user is not connected to the Exchange computer.
  2. The offline Outlook user synchronizes Outlook with the Exchange computer.
In this scenario, the online Outlook user's change to the message is committed to the information store. Therefore, there is no change number for the version conflict for this message. The second Outlook user's change is not committed to the information store until that second user synchronizes Outlook with Exchange. Therefore, there is only one change number that is involved in the version conflict for this message.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------------------------
   28-Oct-2004  22:34  6.5.7232.46     2,528,504  Exchange2003-kb884547-x86-enu.exe

↑ Back to the top


Workaround

To work around this problem, decrease the Exchange diagnostics logging level to 4 or less.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
817903� New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB884547, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 884547
Revision : 10
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 327