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A memory leak occurs in Windows Server 2003 when you send multiple print jobs to a locally attached printer


View products that this article applies to.

Symptoms

When you use a Microsoft Windows Server 2003-based computer to send multiple print jobs to a locally attached printer, a memory leak may occur.

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Cause

This problem occurs when you install a monolithic printer driver or a printer driver that must load and unload the Spoolss.dll library to process a print job.

For example, when you use a monolithic print driver such as the Ricoh AP4510 PCL6 printer driver to process a print job, the Ricoh AP4510 PCL6 printer driver loads and then unloads the Spools.dll library. Every time spoolss.dll is loaded and then unloaded by the printer driver, a memory leak occurs. When you send multiple print jobs, the memory leaks may accumulate.

Note A monolithic driver is a type of device driver that contains all the instructions that the printer must have to function without having to communicate with the miniport driver subsystem. Monolithic drivers bypass the Windows Server 2003 class drivers. Windows Server 2003 class drivers that typically handle device interaction may not interact with the device correctly, if at all, when monolithic drivers are installed. This behavior may cause you to receive a variety of error messages, or Windows Server 2003 may not detect or communicate with the hardware device.

Original equipment manufacturers (OEMs) who want to provide support for a specific hardware device in Windows Server 2003 must create a device driver that can communicate between the hardware device and the Windows Server 2003 class driver for that type of hardware. If a hardware device is listed as being compatible with Windows Server 2003 on the Hardware Compatibility List Web site, you do not have to use a monolithic driver. Instead, contact the OEM for the hardware device, and then obtain an updated driver.

To see the Windows Hardware Compatibility List, visit the following Microsoft Web site:

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 x86
   Date         Time   Version       Size     File name    Platform
   ----------------------------------------------------------------
   02-Sep-2004  15:56  5.2.3790.207  233,984  Spoolss.dll  x86
Windows Server 2003 IA-64
   Date         Time   Version       Size     File name    Platform
   ----------------------------------------------------------------
   02-Sep-2004  15:56  5.2.3790.207  233,984  Spoolss.dll  IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: KB883673, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 883673
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 313