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You may receive a "Could not connect to database" error message when you start the BizTalk Server Base EDI service


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Symptoms

When you start the BizTalk Server Base EDI service in Microsoft BizTalk Server 2004, you may receive an error message that is similar to the following:
	Application Event Error: �Could not connect to database�
	The DB server name instance did not match the real SQL instance name

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Cause

This issue may occur if the database instance name is not specified during installation or if the database instance name has been modified or changed manually after installation. To determine whether you are experiencing this problem, start SQL Server Enterprise Manager, and then verify the database instance name.

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Resolution

If the database instance name is set to local, you either can register the instance of Microsoft SQL Server again, or you can manually change the value of the ServerName entry to localhost in the Esp.ini file. By default, the Esp.ini file is located in the following folder:
C:\Program Files\Microsoft BizTalk Server 2004\EDI\Subsystem
The following sample shows the ServerName entry set to SERVER_01\RAN in the Database section of the Esp.ini file.
[Database]
DBMS=MSS (Msoft) SQL Server 2000
Database=BizTalkEDIDb
AutoCommit=FALSE
ServerName=MYSERVER_01\RAN

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Keywords: KB883548, kbprb, kbtshoot, kbbiztalk2004-2006swept

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Article Info
Article ID : 883548
Revision : 3
Created on : 8/11/2006
Published on : 8/11/2006
Exists online : False
Views : 329