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Changes to your roaming user profile are not saved when you log off and then log on to a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

You log on to a Microsoft Windows Server 2003-based computer as an administrator, and then you make changes to your roaming user profile. When you log off and then log on to the computer, sometimes the changes that you made to your user profile are not saved. You receive error messages that are similar to the following in the Application log:
Type: Error
Source: Userenv
Category: None
Event ID: 1000
Description:
Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. Contact your administrator.
You may experience these symptoms after you install a printer.

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Cause

This problem occurs if the handles to the following registry subkeys are kept open by the Printer Spooler service (Spoolsv.exe):
  • HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\CA
  • HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Root
  • HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\Trust
  • HKEY_CURRENT_USER\Software\Microsoft\SystemCertificates\My
  • HKEY_CURRENT_USER\Software\Policies\Microsoft\SystemCertificates
The open handles prevent the user profile from unloading correctly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
  Date         Time   Version       Size       File name
  ---------------------------------------------------------
  16-Sep-2004  22:33  5.2.3790.211  1,039,872  Setupapi.dll  
Windows Server 2003, 64-bit edition
  Date         Time   Version       Size       File name      Platform
  --------------------------------------------------------------------
  16-Sep-2004  22:36  5.2.3790.211  1,993,728  Setupapi.dll   IA-64
  16-Sep-2004  22:33  5.2.3790.211  1,039,872  Wsetupapi.dll  x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For additional information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB883521, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 883521
Revision : 12
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 315