Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You cannot send messages after you change the routing group configuration, and an event ID 986 message is logged in Exchange 2000 Server


View products that this article applies to.

Symptoms

You cannot send messages from a computer that is running Microsoft Exchange 2000 Server after you change the routing group configuration. Additionally, the following event ID message is logged in the event log on the server:

Event Type: Warning
Source : MSExchangeTransport
Category : Routing Engine/Service
Event ID : 986
Description: GetMessageType returned hr=0x8007000e, MsgType=0xffffffff. Size=0x9c06 (Class=0x0), Prio=0x1, Flags=0x2, TypeOfMsg=0x2000 OrigDN=<> cRRHosts=0, ChkSum=0x0 6RRHs=<>,<>,<>,<>,<>,<>

To send messages, you have to restart the server regularly. When you restart the server, it appears to be working as expected.

↑ Back to the top


Cause

This problem occurs because of a memory leak in the Exchange routing engine. When messages go through the Routing Group connector after you change a routing group configuration, a new object is created. The Exchange routing engine performs an additional reference call on this object. When this behavior occurs, the Exchange routing engine cannot release memory.

↑ Back to the top


Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
      Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Sep-2004  04:47  6.0.6617.6        507,904  Phatq.dll        
   12-Sep-2004  05:04  6.0.6617.6        532,480  Reapi.dll        
				
NOTE: Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378� How to obtain the latest Exchange 2000 Server service pack

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB883309, kbqfe, kbhotfixserver, kbfix, kbprb, kbexchtransport, kbautohotfix

↑ Back to the top

Article Info
Article ID : 883309
Revision : 7
Created on : 10/26/2006
Published on : 10/26/2006
Exists online : False
Views : 218