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An error is logged when you connect a smart USB device to your Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you connect a smart universal serial bus (USB) device to your Microsoft Windows Server 2003-based computer, an error entry that is similar to the following may be recorded in the system event log:
Event Type: Error
Event Source: Removable Storage Service
Event Category: None
Event ID: 15

Description:
RSM cannot manage library PhysicalDrive4. The database is corrupt.
However, the USB device works correctly. For example, read and write operations work correctly.

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Cause

This problem occurs only if Removable Storage is running when the USB device is attached. The problem occurs because the Disk class driver, Disk.sys, requests mode page 0x00. However, because mode page 0x00 is an undefined page, an error occurs.

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Resolution

To resolve this problem, install Windows Server 2003 Service Pack 1. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Jul-2004  19:07  5.2.3790.196       37,888  Disk.sys
Windows Server 2003 64-Bit Enterprise Edition
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   21-Jul-2004  19:07  5.2.3790.196      101,888  Disk.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003presp1fix, kbfix, kbbug, kbqfe, kbhotfixserver, KB875527

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Article Info
Article ID : 875527
Revision : 7
Created on : 8/22/2007
Published on : 8/22/2007
Exists online : False
Views : 317