Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Invalid number" error message when you try to change the forms in the server properties of a printer in Windows Server 2003


View products that this article applies to.

Symptoms

In Microsoft Windows Server 2003, when you try to change the forms in the server properties of a printer, the forms are not changed, and you may receive the following error message:

Invalid number. 'Paper Size' and 'Print Area Margins' should be positive numbers defining a valid paper size and valid printable area margins.

↑ Back to the top


Cause

This problem may occur if the default decimal symbol is changed to a character other than a decimal point (.). This problem typically occurs if regional options other than English (United States) are selected in Regional and Language Options.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 64-Bit Edition
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   27-Jul-2004  17:33  5.2.3790.196    1,142,784  Printui.dll      IA-64
Windows Server 2003, 32-bit editions
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   27-Jul-2004  17:33  5.2.3790.196      549,376  Printui.dll      x86

↑ Back to the top


Workaround

To work around this problem, change the decimal symbol to a decimal point (.). To do this, follow these steps:
  1. Click Start, click Control Panel, and then click Regional and Language Options.
  2. In the Standards and formats area, click Customize.
  3. In the Decimal symbol box, type ., and then click OK.
  4. Click OK to close Regional and Language Options.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbwinservperf, kbfileprintservices, kbbug, kbfix, kbwinserv2003presp1fix, kbautohotfix, KB875521

↑ Back to the top

Article Info
Article ID : 875521
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 494