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FIX: You receive an "Object required" error message when you open a virtual catalog in Commerce Server 2002


View products that this article applies to.

Symptoms

When you open a virtual catalog in Microsoft Commerce Server 2002, you receive the following error message:
An error has occurred while loading.
When you click Show Details, you receive the following error message:

Number: 0x1A8
Description: Object required
Source: Microsoft VBScript runtime error
Note When you build the virtual catalog, the base category is not included in the virtual catalog.

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Cause

The problem occurs when the category name in a base category has a parenthesis character ("( )").

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size     File name
   ----------------------------------------------------
   28-Jul-2004  05:21  4.5.3818.0  954,468  Catalog.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Steps to reproduce the behavior

Create a base catalog

  1. Open the Commerce Server Business Desk (Bizdesk).
  2. On the Catalogs menu, click Catalog Definition Designer.
  3. On the toolbar, click New, and then type Color in the Name box.
  4. In the Available properties list, click Color, click Add, and then click Save & Back.
  5. Click Catalog Editor, click New on the toolbar, and then click New Base Catalog.
  6. Type the following information:
    In this boxType the following
    NameBase
    CurrencyAfghani - AFA
    Product unique IDArtist
    Product variant unique IDAuthor
  7. Click Save & Back.
  8. Click the Base catalog that you created, and then click Open Catalog on the toolbar.
  9. Click Categories, click New, and then type the following information:
    In this boxType the following
    NameBlue(L)
    DescriptionBlue(L)
  10. Click Save & Back, and then click Back.

Create a virtual catalog

  1. On the toolbar, click New, and then click New Virtual Catalog.
  2. Type the following information:
    In this boxType the following
    NameVirtual
    CurrencyAfghani - AFA
  3. Click Save & Back.
  4. Click the virtual catalog that you created, and then click Open Catalog on the toolbar.
  5. In the Include/Exclude pane, click New.
  6. In the Catalog box, click Catalog Picker, click Base catalog, and then click Select.
  7. In the Rule list, click Include Catalog, and then click Done.
  8. Click Save & Back.
  9. Select the virtual catalog that you created, and then click Rebuild on the toolbar.
  10. In the Rebuild Catalog dialog box, click OK.
  11. Click the Virtual catalog, and then click Open Catalog.

    You receive the error message that is mentioned in the "Symptoms" section.

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Keywords: KB875517, kbcommserv2002presp4fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 875517
Revision : 5
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 380