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A tape device unexpectedly goes offline and backup operations that use third-party backup software are not completed successfully in Windows Server 2003


View products that this article applies to.

Symptoms

You are using a tape device with a medium changer device and with third-party backup software on your Microsoft Windows Server 2003-based computer. Sometimes, Windows Server 2003 cannot control the medium changer device. The tape device unexpectedly goes offline, and backup operations are not completed successfully. You have to restart your computer to reset and restore connectivity to the medium changer device and to the tape device.

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Cause

This issue occurs if the third-party backup software is not fully compliant with the Plug and Play feature in Windows Server 2003. When the medium changer and tape devices lose connectivity, the Plug and Play feature in Windows Server 2003 creates new names for the devices. The third-party software processes the names of the devices when the computer restarts. The third-party software does not recognize the new names, and the devices do not work as expected.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
Date         Time   Version        Size    File name
----------------------------------------------------
21-Oct-2004  15:51  5.2.3790.224   15,360  Mcd.sys
21-Oct-2004  15:51  5.2.3790.224   20,480  Tape.sys
 
Windows Server 2003, 64-bit edition
Date         Time   Version       Size    File name
---------------------------------------------------
21-Oct-2004  16:51  5.2.3790.224  38,400  Mcd.sys
21-Oct-2004  16:51  5.2.3790.224  55,808  Tape.sys

Add the Persistence registry entry after you install the hotfix

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To enable this hotfix after you install it, add the Persistence registry entry to the following registry subkey, and then set the registry entry to 1:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Tape
When you set the Persistence registry entry to 1, symbolic names that are used by the Plug and Play feature in Windows Server 2003 are persistent. If you set the Persistence registry entry to 0 (zero), or if you remove the Persistence registry entry, symbolic names are not persistent.

To enable the hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Tape
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type Persistence, and then press ENTER.
  5. Right-click the Persistence registry entry, and then click Modify.
  6. Type 1 in the Value data box, and then click OK.
  7. Quit Registry Editor.
  8. Restart the computer.

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Workaround

To work around this issue, restart the computer.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Notes
  • This fix requires that Tape.sys is being used as the tape class device driver. This fix will have no effect if your backup solution uses a third-party tape class driver.
  • This fix requires that each tape drive must have an electronic embedded serial number. Any tape drive that does not have a serial number will be assigned a non-persistent symbolic name.

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For more information about how to resolve this issue in Microsoft Windows 2000, click the following article number to view the article in the Microsoft Knowledge Base:
889330 A tape device unexpectedly goes offline, and backup operations using third-party backup software are not completed successfully in Windows 2000
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB873337

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Article Info
Article ID : 873337
Revision : 5
Created on : 3/18/2008
Published on : 3/18/2008
Exists online : False
Views : 430