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Windows crashes and you receive a 0x50 Stop error message when you copy an image to the clipboard in Windows Server 2003 or Windows XP


View products that this article applies to.

Symptoms

In Microsoft Windows Server 2003 and in Microsoft Windows XP, when you copy an image to the clipboard, Windows may crash. In this scenario, you receive the following Stop error message:
A problem has been detected and Windows has been shut down to prevent damage to your computer...
Technical information:

*** STOP: 0x00000050 (bc7cf000, 00000000, bf964404, 00000001)
Note The parameters in this error message may vary depending on the location in memory where this Stop error occurred.

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Cause

This problem occurs because the driver that handles Graphics Device Interface (GDI) data, Win32k.sys, may calculate the bitmap header size incorrectly. Therefore, Windows may crash when you copy an image to the clipboard.

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Resolution

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit editions
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   23-Jul-2004  21:53  5.2.3790.196  1,812,992  Win32k.sys
Windows Server 2003 64-bit editions
   Date         Time   Version            Size  File name
   -------------------------------------------------------
   23-Jul-2004  21:46  5.2.3790.196  4,953,088  Win32k.sys

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP service pack 2 installed to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   18-Feb-2005  02:44  5.1.2600.2614   1,835,904  Win32k.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB872797

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Article Info
Article ID : 872797
Revision : 13
Created on : 11/4/2007
Published on : 11/4/2007
Exists online : False
Views : 357