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A 32-bit third-party service quits unexpectedly on a Windows Server 2003 64-bit edition-based computer


View products that this article applies to.

Symptoms

A third-party service may quit unexpectedly on a Microsoft Windows Server 2003 64-bit edition-based computer when the following conditions are true:
  • The third-party service runs as a 32-bit process.
  • The third-party service calls either the GetFileType function or the GetStdHandle function.

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Cause

This problem occurs because the process environment block (PEB) of the 32-bit process has become corrupted. This corruption causes the service to return FILE_TYPE_UNKNOWN to Microsoft Windows on the 64-bit operating system. Windows on 64-bit operating systems is a 32-bit Windows subsystem that you can use to run 32-bit programs on 64-bit versions of Windows.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   01-Jul-2004  17:22  5.2.3790.186      449,536  Wow64.dll        IA-64
   01-Jul-2004  17:22  5.2.3790.186      527,360  Wow64win.dll     IA-64
   21-Apr-2004  16:35                        271  Branches.inf
   01-Jul-2004  17:56                     10,119  Kb872768.cat
   01-Jul-2004  17:29                        354  Updatebr.inf
   01-Jul-2004  17:29                      5,762  Update_rtmqfe.inf

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB872768, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 872768
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 257