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Error message in various screens in Microsoft Dynamics SL: "System Message 10232 - Assertion failure"


Symptoms

You receive an error message that resembles the following in various screens in Microsoft Dynamics SL 7.0: o{17944DF6-4CA9-4C98-98D7-03952B59E82Ct{17944DF6-4CA9-4C98-98D7-03952B59E82C.{17944DF6-4CA9-4C98-98D7-03952B59E82C:
System Message 10232 - Assertion failure! File: % Line: % Expression: %s Hit OK to stop program, and report the error to Microsoft Support, noting the failed expression, file name and line number.

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Cause

This error message may occur for several reasons.
  • Occurs when a screen customization is corrupted or conflicting with another customization. See resolution 1.
  • Occurs during the Transaction Import process because the data file or control macro does not correctly match the screen that you are importing into. See Resolution 2.
  • Occurs when the version of the swimapi.dll file that is installed on the local drive differs from the version that is installed on the Microsoft Dynamics SL file server. See resolution 3.
  • Occurs when you click Paste in the Template (98.230.00) screen. See Resolution 4
  • Occurs when you try to open a screen that contains a grid. See Resolution 5.
  • Occurs when you try to select a printer for a report template. See Resolution 6.

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Resolution

Resolution 1


Determine whether a screen customization is corrupted or conflicting with another customization by opening the screen while in standard mode. To do this, follow these steps:


If you are running Microsoft Dynamics SL 7.0 and later versions, follow these steps:
  1. On the status bar, click Self.
  2. Click Standard, and then click OK..
  3. Open the customized screen.
    Note If the System Message 10232 does not occur when you open the screen while in Standard Mode, the customization is the source of the problem and may have to be re-created.

If you are running Microsoft Dynamics SL 6.5, follow these steps:
  1. On the Customize menu, click Select Level.
  2. Click Standard, and then click OK.
  3. Open the customized screen.
    Note If the System Message 10232 does not occur when you open the screen while in Standard Mode, the customization is the source of the problem and may have to be re-created.

Resolution 2


Create a data file and control macro that correctly matches the screen that you are importing the data into.
Note See the Transaction Import Help file or Transaction Import manual for more information about how to create data files and control macros that are correctly formatted.

Resolution 3


Verify that the Microsoft Dyamics SL kernel build that is installed on the local drive is the same as on the file server . To do this, follow these steps:
  1. Start Microsoft Dynamics SL, and then click Help.
  2. On the Help menu, click About Microsoft Dynamics SL, and note the version number.
  3. Repeat steps 1 and 2 on the Microsoft Dynamics SL file server.

Note If the version numbers differ, install the appropriate Microsoft Dynamics SL update on the local drive.
For more information about the Microsoft Dynamics SL kernel builds, click the following article number to view the article in the Microsoft Knowledge Base:

850447 List of versions, releases, and kernel builds of Microsoft Dynamics SL


Resolution 4


Delete, and then re-create the template. To do this, follow these steps:
  1. Open the appropriate screen.
  2. Click Actions, click Template, and then type the ID in the Template ID box.
  3. Click Delete, and then click Yes when you are prompted with the following confirmation message:
    System Message 12 - Are you sure you want to delete?
  4. Re-Create the template by using the appropriate values.

Resolution 5


Manually register the MSIGRID.OCX file. To do this, follow these steps:
  1. Locate the MSIGRID.OCX file in the following paths:
    32-bit Operating System: <SystemDrive> :\Windows\System32
    64-bit Operating System: <SystemDrive> :\Windows\SysWOW64

    Note <SystemDrive> represents the drive on which Microsoft Windows is installed.
  2. Right-click the MSIGRID.OCX file, and then click Open With .
  3. In the Windows dialog box, click Select the program from a list , and then click OK .
  4. In the Open With dialog box, click Browse .
  5. Locate and then open the following folder: 32-bit Operating System: <SystemDrive> :\Windows\System32 64-bit Operating System: <SystemDrive> :\Windows\SysWOW64
  6. Double-click the Regsvr32.exe file, and then click OK .
  7. Locate and then open the following folder: 32-bit Operating System: <SystemDrive> :\Windows\System32 64-bit Operating System: <SystemDrive> :\Windows\SysWOW64
  8. Click OK when you receive the following message:
    RegSvr32 - DllRegisterServer in SystemDrive :\windows\system32\msigrid.ocx succeeded.

Resolution 6


Delete the template, and then select the desired printer in the Printer Options (98.220.00) screen before you re-create the template.
Note: When you create a template, the destination printer's driver information for the printer that is specified in the Printer Options (98.220.00) screen is coded into the template.

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Keywords: kberrmsg, kbsurveynew, kbexpertisebeginner, kbtshoot, kbprb, kbexpertiseinter, kbmbstransactionimport, kbmbspartner, kbmbsmigrate, kb

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Article Info
Article ID : 871319
Revision : 1
Created on : 1/7/2017
Published on : 7/24/2011
Exists online : False
Views : 100