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You are prompted to install drivers for an upgraded device when you upgrade the firmware on a SCSI device in Windows Server 2003


View products that this article applies to.

Symptoms

When you upgrade the firmware on a small computer system interface (SCSI) device and then restart Microsoft Windows Server 2003, the Add New Hardware Wizard unexpectedly starts. Then, the wizard prompts you for the location of drivers to install for the upgraded device.

Note Examples of a SCSI device include a hard disk, a redundant array of independent disks (RAID) controller, and a tape drive.

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Cause

This issue occurs because the SCSI device is detected as a new device after the firmware upgrade.

The Microsoft Windows Plug and Play manager obtains the firmware revision number from a SCSI device. This revision number then becomes part of the device's Plug and Play ID string. When the upgraded device is enumerated, the new firmware revision number generates a new unique Plug and Play ID for the device. Therefore, the device is recognized as a new device instead of as the same device that has already been enumerated.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit editions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Jul-2004  16:01  5.2.3790.195      127,488  Scsiport.sys 
Windows Server 2003 64-bit editions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Jul-2004  03:02  5.2.3790.195      292,352  Scsiport.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbbug, kbfix, kbwinserv2003presp1fix, kbqfe, kbhotfixserver, KB871268

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Article Info
Article ID : 871268
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 335