Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You receive an error message when you try to use an HTTP POST to upload a large file to a Web server through an Internet Security and Acceleration Server 2000 computer


View products that this article applies to.


Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows Registry

↑ Back to the top


Symptoms

When you try to use an HTTP POST to upload a large file to a Web server, you receive either or both of the following error messages:
Host not found
Connection aborted

↑ Back to the top


Cause

This problem occurs when the following conditions are true:
Your computer accesses the Microsoft Internet Information Services (IIS) Web server through a Microsoft Internet Security and Acceleration (ISA) Server 2000 computer.
The IIS server is configured to require NTLM authentication.
The upstream Web server sends a "401 Authentication Required" response before the HTTP POST operation is completed.
If the ISA Server computer receives a "401 Authentication Required" response from the upstream Web server before the HTTP POST operation is completed, the computer continues to send data to the Web server instead of forwarding this response to the downstream client computer. This behavior causes the Web server to respond with a "400 Bad Request" response to the ISA Server computer. The ISA Server computer then closes the connection to the upstream Web server and sends a "500 Bad Gateway" response to the client computer.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:Note If additional issues occur or any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:

Prerequisites

To install this hotfix, you must have ISA Server 2000 Service Pack 2 installed.

For additional information about how to obtain ISA Server 2000 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
313139 How to obtain the latest Internet Security and Acceleration Server 2000 service pack

Restart requirement

You do not have to restart your computer to install this hotfix. However, the following services are automatically restarted during the installation of this hotfix:
Microsoft Web Proxy
Routing and Remote Access
Microsoft Firewall
Microsoft ISA Server Control

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version        Size      File name 
   --------------------------------------------------------
   12-Oct-2004  23:34   3.0.1200.404   401,912   W3proxy.exe	
 	

Hotfix installation instructions

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

After you install this hotfix, you must configure a registry entry to enable the hotfix. To do this, follow these steps:
1.Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3Proxy\Parameters
3.On the Edit menu, point to New, and then click DWORD Value.
4.Type AllowPrematureServerResponse as the entry name, and then press ENTER.
5.Right-click AllowPrematureServerResponse, and then click Modify.
6.In the Value data box, type a value of 1, and then click OK.
7.Quit Registry Editor.
8. Restart the Microsoft Web Proxy service. To do this:
a. Click Start, click Run, type services.msc, and then click OK.
b. Right-click Microsoft Web Proxy, and then click Restart.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Internet Security and Acceleration Server 2000.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB870989, kbbug, kbfix, kbfirewall, kbhotfixserver, kbqfe

↑ Back to the top

Article Info
Article ID : 870989
Revision : 5
Created on : 6/14/2007
Published on : 6/14/2007
Exists online : False
Views : 308