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A memory leak occurs in an application using the Volume Shadow Copy Service on a computer that is running Windows Server 2003


View products that this article applies to.

Symptoms

A memory leak may occur in an application that uses the Volume Shadow Copy service on a computer that is running Microsoft Windows Server 2003.

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Cause

This problem occurs because of a memory leak in cryptographic services (Cryptsvc.dll). Any application that is using cryptographic services, such as the Volume Shadow Copy service, may experience this problem.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit x86-based versions
Date         	Time   	Version            Size    	File name
--------------------------------------------------------------------
29-Jun-2004  	21:32  	5.2.3790.186       52,224  	Cryptsvc.dll
Windows Server 2003, 64-bit Itanium-based versions
Date         	Time   	Version            Size    	File name
--------------------------------------------------------------------
29-Jun-2004  	21:27  	5.2.3790.186       129,024 	Cryptsvc.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB870973

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Article Info
Article ID : 870973
Revision : 14
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 484