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You receive a "Login failed for user" error message when the BizTalk Server 2004 Configuration Wizard creates databases


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Symptoms

When you run the Microsoft BizTalk Server 2004 Configuration Wizard and you choose the option to create a new BizTalk Server Group, you receive an error message that is similar to the following when the Configuration Wizard tries to create the databases that BizTalk Server will use:

Microsoft BizTalk Server 2004 Configuration Wizard

Deploying BAM infrastructure:
Failed to set up BAM database(s).
Cannot open database requested in login 'BAMPrimaryImport'.
Login fails. Login failed for user 'BizTalk\BizTalkUser'.

Retry / Cancel
Note In the error message, BizTalk\BizTalkUser is a placeholder for the actual domain name and account name for the currently logged on user.

When you receive this error message, you may receive an error message that is similar to the following in SQL Profiler if you run a Profiler trace against the Microsoft SQL Server where the BizTalk Server 2004 Configuration Wizard is installing the BizTalk Server databases:

2004-06-17 16:18:33.75 spid58 FCB::CreateFile() failed with error 80 for file C:\Program Files\Microsoft SQL Server\MSSQL\data\BAMPrimaryImport.mdf.

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Cause

This behavior occurs if an .mdf file or an .ldf file already exists in the \Program Files\Microsoft SQL Server\MSSQL\data folder of your SQL Server that has the same name as the .mdf file or the .ldf file that the BizTalk Server 2004 Configuration Wizard is trying to create. The names of the .mdf file and the .ldf file that are created for the databases are derived from the name of the database that is specified in the BizTalk Server 2004 Configuration Wizard with an .mdf and an .ldf extension appended.

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Resolution

To resolve this behavior, use one of the following methods:
  • Delete any .mdf files or .ldf files that have names that match the names of any databases that you are creating.
  • Choose database names that do not match the names of any .mdf files or .ldf files that already exist in the \Program Files\Microsoft SQL Server\MSSQL\data folder of your SQL Server.

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Status

This behavior is by design.

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References

For more information about BizTalk Server 2004, visit the following Microsoft Web site:

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Keywords: KB870913, kbprb

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Article Info
Article ID : 870913
Revision : 3
Created on : 6/23/2004
Published on : 6/23/2004
Exists online : False
Views : 424