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The number of open registry key handles increases when you use the Automated System Recovery feature of the Windows Backup tool in Windows Server 2003 and in Windows XP


View products that this article applies to.

Symptoms

When you do either of the following on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP, you may experience an unexpected increase in the number of registry key handles, process handles, and thread handles that remain open:
  • You use the Automated System Recovery (ASR) feature of the Windows Backup tool.
  • You use a program or a service that calls the AsrCreateStateFileW function.
These open handles may eventually cause the performance of your computer to decrease.

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Cause

This problem occurs if the EnumerateInstanceKeys function opens a registry key and then does not close the registry key that is currently open before it opens another registry key,

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Resolution

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version       Size       File name
---------------------------------------------------------
28-Jul-2004  23:45  5.2.3790.196  1,012,736  Syssetup.dll 

Windows Server 2003, 64-Bit Edition

Date         Time   Version       Size       File name
---------------------------------------------------------------
28-Jul-2004  23:45  5.2.3790.196  1,835,520  Syssetup.dll  IA-64
28-Jul-2004  23:45  5.2.3790.196  1,012,736  Wsyssetup.dll  x86

Windows XP service pack information

To resolve this problem, install Windows XP Service Pack (SP2) or later. For additional information about how to obtain the latest service pack for Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

Date         Time   Version        Size     File name
--------------------------------------------------------
01-Jul-2004  05:55  5.1.2600.1550  940,544  Syssetup.dll  

Windows XP, 64-Bit Edition

Date         Time   Version            Size    File name
----------------------------------------------------------------
01-Jul-2004  06:00  5.1.2600.1550  1,808,896  Syssetup.dll  IA-64
01-Jul-2004  05:55  5.1.2600.1550    940,544  Wsyssetup.dll  x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB870677

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Article Info
Article ID : 870677
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 352