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How to resolve problems that occur with the JET component and with the MDAC component


View products that this article applies to.

Summary

The products that are listed in the "Applies To" section rely on several Microsoft Windows components to function correctly. These components include DCOM, JET, and MDAC technologies. If the installation of one of these components is corrupted, or the components are installed in the wrong order, the programs that are listed in the "Applies To" section may not be installed correctly, or may not work as expected. This article describes the symptoms that you may experience, and provides the steps to resolve the problem.

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Symptoms

When you try to install the products that are listed in the "Applies To" section, you may experience one or more of the following symptoms with Microsoft Picture It! and with Microsoft Digital Image:
  • When you try to install Picture It!, the Picture It! installation program determines that the MDAC component must be installed. After you install the MDAC component, the Setup program requires that you restart the computer. After you restart the computer, when you try to install Microsoft Picture It! again, the Setup program installs the MDAC component again and requires that you restart the computer again. This is a never ending cycle.
  • In the middle of the installation, you receive the following error message:
    Installation Wizard has been interrupted.
  • When you try to install Picture It!, you receive an error message that resembles the following:
    Error 1911: Could not register Type Library for file C:\Program Files\Common Files\Microsoft Shared\Shoebox\ShoeboxU.dll
When you start Picture It! and try to select an item from the Gallery or try to select a clip art image, you may experience one or more of the following symptoms:
  • You receive the following error message:
    Catalog database has become corrupted.
  • When you try to use clip art, no clip art is found. There is a beige box that has no place holders and no thumbnails. Instead of thumbnails, you see white boxes with red "X"s.
When you use any one of the other products that are listed in the "Applies To" section, you may experience the following symptom when you start the program:
  • The program stops responding (hangs). You see an hourglass. But the program never fully opens.

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Cause

These problems may occur if the following components have been installed out of order, have not been installed, or if their installations have been corrupted:
  • The DCOM component
  • The JET component
  • The MDAC component
Excessive temporary files may have prevented a successful installation of these components.

All versions of the following programs rely on these three components to function correctly:
  • Microsoft Picture It
  • Microsoft Digital Image
  • Microsoft Works
  • Microsoft Streets & Trips
  • Microsoft MapPoint
  • Microsoft AutoRoute
  • Microsoft Money
  • Microsoft Encarta
  • Microsoft Internet Explorer
Additionally, if you experience the symptom that occurs when you try to use clip art, and you see white boxes instead of thumbnails, there might be problems with your installation of Microsoft Internet Explorer. After you follow the steps that are listed in the "Resolution" section, reinstall Internet Explorer to resolve this problem.

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Resolution

You can use the steps to resolve these problems if the problem involves the DCOM component, the JET component, or the MDAC component.

The only way to reinstall the DCOM component on a Microsoft Windows 2000-based computer, a Microsoft Windows Millennium Edition-based computer, a Microsoft Windows XP-based computer, or a Windows Vista-based computer is to reinstall Microsoft Windows. The DCOM component is a core component of the operating system and cannot be removed or installed separately.

You must install the current JET component version before you install the current MDAC component version. In earlier versions of the JET component and the MDAC component, it has been the practice to install the JET component after the MDAC component. This was the practice because the JET component relies on ODBC drivers being loaded on the system. At first, the ODBC drivers were installed with the MDAC component. However, the MDAC component, Microsoft Windows Server 2003, Windows XP, and Windows Vista come with ODBC drivers preinstalled. However, Microsoft Windows 98, Windows Millennium Edition, and Microsoft Windows NT do not come with ODBC drivers preinstalled. The JET component now copies the ODBC drivers to the computer. However, it relies on the MDAC component to create the appropriate registry entries to use the ODBC drivers.

For more information about how to install the JET component, click the following article number to view the article in the Microsoft Knowledge Base:

829558 Information about Jet 4.0 Service Pack 8



Download and install all the available Microsoft Windows updates from the Windows Update Web site before you continue with these steps. You may have to return to the Windows Update Web site multiple times to download all the available updates. To do this, follow these steps:
  1. Visit the following Microsoft Web site:
  2. When the page is finished loading, click Scan for updates.
  3. You will see a list of available updates in the following three categories:
    • Critical Updates and Service Packs
    • Windows Updates
    • Driver Updates
Install all the available updates in all the categories that apply to the computer that you are using. If you are running Windows 98, you do not have to install all the foreign language packs that appear when Windows Update scans your computer for updates. If you are not sure, it is best to install the update.

To resolve this problem, follow the steps for the operating system that you are using.

Windows 98

Remove the program

To remove the program that is displaying the problem and to remove any earlier versions of that same program that are installed on your computer, follow these steps:
  1. Click Start, point to
    Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the program, and then click
    Add/Remove.
  4. Follow the prompts to remove the program.

Delete the temporary files

  1. Open My Computer.
  2. Right-click Local Disk C:, and then click
    Properties.
  3. On the General tab, click Disk Cleanup.

    Note You may have to wait if you have lots of files.
  4. When the Disk Cleanup for (C:) window appears, click to select the following check boxes:
    • Temporary Internet Files
    • Recycle Bin
    • Temporary Files
  5. Click OK, and then click
    Yes when you are prompted to delete files.
  6. When the cleanup process is complete, close the properties window and the My Computer window.

Download the Microsoft Libraries Update

  1. Visit the following Microsoft Web site:
  2. Click Next.
  3. Read the License Agreement. If you agree, click
    Accept License Agreement and begin download now (For use with all language versions), and then click Next.
  4. When the file download box appears, click
    Save.
  5. In the Save in box, click
    Desktop, and then click Save.
Note Do not install the update now.

Download DCOM98 for Windows 98, version 1.3

  1. Visit the following Microsoft Web site:
  2. Click the link to read the Microsoft Software License Terms Microsoft Software License Terms.
  3. On the Microsoft Software License Terms page, scroll to the bottom of the page, and then click Download DCOM98 for Windows 98, version 1.3.
  4. Click DCOM98 for Windows 98.
  5. When the File Download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.
Note Do not install the update now.

Download Jet 4 SP8

  1. Visit the following Microsoft Web site:
  2. Locate the "For Computers That Are Running Microsoft Windows 95, Microsoft Windows 98 and Microsoft Windows NT version 4.0" section, and then click Jet40SP8_9xNT.exe.
  3. When the File Download box appears, click
    Save.
  4. In the Save in box, click
    Desktop, and then click Save.
Note Do not install the update now.

Download the MDAC 2.8 component

  1. Visit the following Microsoft Web site:
  2. In the Keywords box, type
    mdac, and then click Go.
  3. In the list of found files, click the MDAC 2.8 link. Typically, this is the first link in the list.
  4. On the right side of the page that appears, click
    Download.
  5. When the File Download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.

Download the Runtifix.exe file

  1. Visit the following Microsoft Web site:
  2. When the File Download box appears, click
    Save.
  3. In the Save in box, click
    Desktop, and then click Save.
Note Do not run the Runtifix.exe file now.

Enable a clean start

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. Click to select the Selective Startupcheck box, and then click to clear the following check boxes:
    • Process Config.sys file
    • Process Autoexec.bat file
    • Process Winstart.bat file (if it is not already unavailable)
    • Load startup group items
  3. On the Win.ini tab, double-click
    [windows].
  4. Click to clear all the check boxes for all the lines that begin with Load= or that begin with Run=.
  5. Click Apply, and then click OK to close the System Configuration Utility.
  6. Click Yes when you are prompted to restart the computer.

Install all the files

  1. Double-click the SPEU.exe file on the desktop.
  2. After you install the Libraries Update, double-click the
    DCOM98.exe file. Follow the prompts to complete the installation.
  3. When you are prompted to restart your computer, click
    Yes.
  4. Double-click the JET40SP8_9xNT.exe file on the desktop. Follow the prompts to complete the installation.
  5. After the installation is complete, wait 30 seconds.
  6. Click Start, and then click
    Shutdown.
  7. Click Restart, and then click
    OK.
  8. Double-click the MDAC_TYP.exe file on the desktop. Follow the prompts to complete the installation.
  9. When the installation is complete, click
    Close.
  10. Click Start, and then click
    Shutdown.
  11. Click Restart, and then click
    OK.
  12. Double-click the Runtifix.exe file on the desktop.
  13. Click Yes when you are prompted to continue if you have Microsoft Internet Explorer 4.0 or a later version installed on your computer.
  14. If you are prompted to confirm replacing new files with older files, click No to all.
  15. When you are prompted to restart your computer, click
    Yes.

Reinstall the program and return to a Normal startup

  1. Reinstall the program that displayed the symptoms.
  2. After the installation is complete, click
    Start, click Run, type
    msconfig in the Open box, and then click OK.
  3. Click Normal startup, and then click
    OK.
  4. When you are prompted to restart your computer, click
    Yes.

Windows Millennium Edition

Remove the program

To remove the program that is displaying the problem and any earlier versions of that program that are installed on your computer, follow these steps:
  1. Click Start, point to
    Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the program, and then click
    Add/Remove.
  4. Follow the prompts to remove the program.

Delete the temporary files

  1. Open My Computer.
  2. Right-click Local Disk C:, and then click
    Properties.
  3. On the General tab, click Disk Cleanup.

    Note You may have to wait if you have lots of files.
  4. When the Disk Cleanup for (C:) window appears, click to select the following check boxes:
    • Temporary Internet Files
    • Recycle Bin
    • Temporary Files
  5. Click OK, and then click
    Yes when you are prompted to delete the files.
  6. When the cleanup process has finished, close the properties window and the My Computer window.

Download Jet 4 SP8

  1. Visit the following Microsoft Web site:
  2. Locate the "For Computers That Are Running Microsoft Windows Millennium Edition" section, and then click
    Jet40SP8_WMe.exe
  3. When the File Download box appears, click
    Save.
  4. In the Save in box, click
    Desktop, and then click Save.

Download the MDAC 2.8 component

  1. Visit the following Microsoft Web site:
  2. In the Keywords box, type
    mdac, and then click Go.
  3. In the list of found files, click the MDAC 2.8 link. Typically, this is the first link in the list.
  4. On the right side of the page that appears, click
    Download.
  5. When the File Download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.

Download the Runtifix.exe file

  1. Visit the following Microsoft Web site:
  2. When the file download box appears, click
    Save.
  3. In the Save in box, select
    Desktop, and then click Save.
Note Do not run the Runtifix program now.

Enable clean boot

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. Click to select the Selective Startupcheck box, and then click to clear all the check boxes under Selective Startup.
  3. On the Static VxDs tab, click to select the following check boxes:
    • VNETSUP
    • NDIS
    • VNETBIOS
    • VREDIR
  4. On the Startup tab, click to select the
    StateMgr check box.
  5. Click OK to close the System Configuration Utility.
  6. Click Yes when you are prompted to restart the computer.

Install all the files

  1. Double-click the JET40SP8_WMe.exe file on the desktop. Follow the prompts to complete the installation.
  2. After installation is complete, wait 30 seconds.
  3. Click Start, and then click
    Shutdown.
  4. Click Restart, and then click
    OK.
  5. Double-click the MDAC_TYP.exe file on the desktop. Follow the prompts to complete the installation.
  6. When the installation is complete, click
    Close.
  7. Click Start, and then click
    Shutdown.
  8. Click Restart, and then click
    OK.
  9. Double-click the Runtifix.exe file on the desktop.
  10. Click Yes when you are prompted to continue if you have Microsoft Internet Explorer 4.0 or a later version installed on your computer.
  11. If you are prompted to confirm replacing new files with older files, click No to all.
  12. When you are prompted to restart your computer, click
    Yes.

Install the program and return to a Normal startup

  1. Install the program that displayed the symptoms.
  2. After installation is complete, click
    Start, click Run, type
    msconfig in the Open box, and then click OK.
  3. Click Normal startup, and then click
    OK.
  4. When you are prompted to restart your computer, click
    Yes.

Windows 2000

Remove the program

To remove the program that is displaying the problems and any earlier versions of that program that are installed on your computer, follow these steps:
  1. Click Start, point to
    Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the program, and then click
    Add/Remove.
  4. Follow the prompts to remove the program.

Delete the temporary files

  1. Open My Computer.
  2. Right-click Local Disk C:, and then click
    Properties.
  3. On the General tab, click Disk Cleanup.

    Note You may have to wait if you have lots of files.
  4. When the Disk Cleanup for (C:) window appears, click to select all the following check boxes:
    • Temporary Internet Files
    • Recycle Bin
    • Temporary Files
  5. Click OK, and then click
    Yes when you are prompted to delete the files.
  6. When the cleanup process is complete, close the properties window and the My Computer window.

Download Jet 4 SP8

  1. Visit the following Microsoft Web site:
  2. Locate the section that is named For Computers That Are Running Microsoft Windows 2000, and then click
    Windows2000-KB829558-x86-ENU.exe.
  3. When the file download box appears, click
    Save.
  4. In the Save in box, click
    Desktop, and then click Save.

Download MDAC 2.8

  1. Visit the following Microsoft Web site:
  2. In the Keywords box, type
    mdac, and then click Go.
  3. In the list of found files, click the first link
    MDAC 2.8.
  4. In the upper-right corner of the page that appears, click
    Download
  5. When the file download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.

Download Runtifix.exe

  1. Visit the following Microsoft Web site:
  2. When the file download box appears, click
    Save.
  3. In the Save in box, select
    Desktop, and then click Save.
Note Do not run the Runtifix program now.

Install all the files

  1. Restart the computer.
  2. As the computer starts, press and hold the F8 key until you see the Windows 2000 Advanced Options Menu.
  3. Select Safe Mode, and then press Enter.
  4. Double-click
    Windows2000-KB829558-x86-ENU.exe on the desktop. Follow the prompts to complete the installation.
  5. After installation is complete, wait 30 seconds.
  6. Click Start, and then click
    Shutdown.
  7. Click Restart, and then click
    OK.
  8. As the computer starts, press and hold the F8 key until you see the Windows 2000 Advanced Options Menu.
  9. Click Safe Mode, and then press ENTER.
  10. Double-click MDAC_TYP.exe on the desktop, and then follow the prompts to complete the installation.
  11. When installation is complete, click
    Close.
  12. Click Start, and then click
    Shutdown.
  13. Click Restart, and then click
    OK.
  14. As the computer starts, press and hold the F8 key until you see the Windows 2000 Advanced Options Menu.
  15. Click Safe Mode, and then press ENTER.
  16. On the desktop, double-click
    Runtifix.exe.
  17. Click Yes when you are prompted to continue if Microsoft Internet Explorer 4.0 or a later version is installed on your computer.
  18. If you are prompted to confirm replacing new files with older ones, click No to all.
  19. When you are prompted to restart your computer, click
    Yes.
  20. As the computer starts, press and hold the F8 key until you see Windows 2000 Advanced Options Menu.
  21. Click Safe Mode, and then press ENTER.

Install program

  1. Install the program that displayed the symptoms.
  2. Restart the computer.

Windows XP

Remove the program

To remove the program that is displaying the problem and to remove any earlier versions of that program that are installed on your computer, follow these steps:
  1. Click Start, and then click
    Control Panel.
  2. Double-click Add/Remove Programs.
  3. Click the program that you want to remove, and then click
    Add/Remove.
  4. Follow the prompts to remove the program.

Delete the temporary files

  1. Open My Computer.
  2. Right-click Local Disk C:, and then click
    Properties.
  3. On the General tab, click Disk Cleanup.

    Note You may have to wait if you have lots of files.
  4. When the Disk Cleanup for (C:) window appears, click to select all the following check boxes:
    • Temporary Internet Files
    • Recycle Bin
    • Temporary Files
  5. Click OK, and then click
    Yes when you are prompted to delete the files.
  6. When the cleanup process has finished, close the properties window and the My Computer window.

Download the Jet 4 SP8 component

  1. Visit the following Microsoft Web site:
  2. Locate the "For Computers That Are Running Microsoft Windows XP" section, and then click the
    WindowsXP-KB829558-x86-ENU.exe file.
  3. When the File Download box appears, click
    Save.
  4. In the Save in box, click
    Desktop, and then click Save.

Download the MDAC 2.8 component

  1. Visit the following Microsoft Web site:
  2. In the Keywords box, type
    mdac, and then click Go.
  3. In the list of found files, click the MDAC 2.8 link. Typically this is the first link in the list.
  4. In the upper-right corner of the page that loads, click
    Download.
  5. When the File Download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.

Download the Runtifix.exe file

  1. Visit the following Microsoft Web site:
  2. When the File Download box appears, click
    Save.
  3. In the Save in box, click
    Desktop, and then click Save.
Note Do not run the Runtifix program now.

Enable a clean start

  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. Click to select the Selective Startupcheck box, and then click to clear all the following check boxes:
    • Process SYSTEM.ini file
    • Process WIN.ini file
    • Load Startup Items
  3. On the Services tab, click to select the
    Hide All Microsoft Services check box.
  4. Click Disable All.
  5. Click Apply, and then click
    Close to close the System Configuration Utility.
  6. Click Restart when you are prompted to restart the computer.

Install the files

  1. Double-click
    WindowsXP-KB829558-x86-ENU.exe on the desktop, and then follow the prompts to complete the installation.
  2. After the installation is complete, wait 30 seconds.
  3. Click Start, and then click
    Shutdown.
  4. Click Restart, and then click
    OK.
  5. Double-click the MDAC_TYP.exe file on the desktop, and then follow the prompts to complete the installation.
  6. When the installation is complete, click
    Finish, and then the computer restarts.
  7. Double-click the Runtifix.exe file on the desktop.
  8. Click Yes when you are prompted to continue if you have Microsoft Internet Explorer 4.0 or a later version installed on your computer.
  9. If you are prompted to confirm replacing new files with older files, click No to all.
  10. When you are prompted to restart your computer, click
    Yes.

Install the program and return to a Normal startup

  1. Install the program that displayed the symptoms.
  2. After installation is complete, click
    Start, click Run, type
    msconfig in the Open box, and then click OK.
  3. Click Normal startup, and then click
    OK.
  4. When you are prompted to restart your computer, click
    Yes.

Windows Vista

Remove the program

To remove the program that is displaying the problem and to remove any earlier versions of that program that are installed on the computer, follow these steps:
  1. Open the Programs and Features item in Control Panel. To do this, click StartStart button , type appwiz.cplin the Start Search box, and then press ENTER.
  2. Click the program that you want to remove, and then click
    Uninstall/Change.
  3. Follow the prompts to remove the program.

Delete the temporary files

  1. Click StartStart button , type Disk Cleanup in the Start Search box, and then select Disk Cleanup in the Programs list.

    Note You may have to wait if you have lots of files.
  2. When the Disk Cleanup for (C:) dialog box appears, click to select all the following check boxes:
    • Temporary Internet Files
    • Recycle Bin
    • Temporary Files
  3. Click OK, and then click
    Yes when you are prompted to delete the files.
  4. When the cleanup process has finished, close the properties window and the Computer window.

Download the MDAC 2.8 component

  1. Visit the following Microsoft Web site:
  2. In the Keywords box, type
    mdac, and then click Go.
  3. In the list of found files, click the MDAC 2.8 link. Typically this is the first link in the list.
  4. In the upper-right corner of the page that appears, click
    Download.
  5. When the File Download box appears, click
    Save.
  6. In the Save in box, click
    Desktop, and then click Save.

Download the Runtifix.exe file

  1. Visit the following Microsoft Web site:
  2. When the File Download box appears, click
    Save.
  3. In the Save in box, click
    Desktop, and then click Save.
Note Do not run the Runtifix program now.

Enable a clean start

  1. Click Startthe Start button , type msconfigin the Start Search box, and then press ENTER.

    User Account Control permission If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
  2. Click to select the Selective Startupcheck box, and then click to clear all the following check boxes:
    • Process SYSTEM.ini file
    • Process WIN.ini file
    • Load Startup Items
  3. On the Services tab, click to select the
    Hide All Microsoft Services check box.
  4. Click Disable All.
  5. Click Apply, and then click
    Close to close the System Configuration Utility.
  6. Click Restart when you are prompted to restart the computer.

Install the files

  1. On the desktop, double-click the MDAC_TYP.exe file, and then follow the prompts to complete the installation.
  2. When the installation is complete, click
    Finish. The computer restarts.
  3. On the desktop, double-click the Runtifix.exe file.
  4. Click Yes when you are prompted to continue if you have Microsoft Internet Explorer 4.0 or a later version installed on the computer.
  5. If you are prompted to confirm replacing new files with earlier files, click No to all.
  6. When you are prompted to restart the computer, click
    Yes.

Install the program and return to a Normal startup

  1. Install the program that displayed the symptoms.
  2. After the installation is complete, click Startthe Start button , type msconfigin the Start Search box, and then press ENTER.
  3. Click Normal startup, and then click
    OK.
  4. When you are prompted to restart the computer, click
    Yes.

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More Information

Notes specific to Picture It! and to Digital Image installations

If you receive an "Invalid syntax" error message after you follow the steps that are listed in the "Resolution" section, follow these steps:
  1. Exit your version of Picture It! or Digital Image.
  2. Search the hard disk drives for the User.sbc file. You may have to set the option to search for hidden files.
  3. Rename the User.sbc file to
    user.old.
  4. Restart Picture It! or Digital Image.
The User.sbc file is automatically rebuilt.

If you install the MDAC component before you install the JET component, you may receive an "Interrupted Installation" error message when you try to install Picture It!. To resolve this problem, follow the steps to start the computer by using a clean boot installation. You can find these steps in the "Enable a clean start" section. Reinstall the JET component and the MDAC component, in that order.

If these steps do not resolve the problem where the program stops responding (hangs) when you start it, update the video card drivers.

For more information about how to update video card drivers, click the following article number to view the article in the Microsoft Knowledge Base:

248326 Your computer may stop responding when you start Streets and Trips or MapPoint

For more information about how to perform a clean boot installation, click the following article numbers to view the articles in the Microsoft Knowledge Base:

192926 How to perform clean-boot troubleshooting for Windows 98

267288 How to perform a clean boot in Windows Millennium Edition

310353 How to perform a clean boot in Windows XP

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Keywords: kb, kbprb, kbentirenet, kberrmsg, kbhowto, dftsdahomeportal

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Article Info
Article ID : 870630
Revision : 2
Created on : 4/9/2020
Published on : 4/9/2020
Exists online : False
Views : 318