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You receive a "5.2.1" non-delivery report when you send an e-mail message to a public folder on Exchange Server 2003 or on Exchange 2000 Server


View products that this article applies to.

Symptoms

When you try to send an e-mail message to a public folder, you receive a non-delivery report (NDR) that is similar to the following:
Your message did not reach some or all of the intended recipients.
Subject: Subject
Sent: Date Time
The following recipient(s) could not be reached:
RecipientName on Date Time
The message reached the recipient's e-mail system, but delivery was refused. Attempt to resend the message. If it still fails, contact your system administrator.

<ExchangeServerName.DomainName.com #5.2.1>

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Cause

This problem occurs if all the following conditions are true:
  • You are running Microsoft Exchange Server 2003 or Microsoft Exchange 2000 Server in a Microsoft Windows Server 2003 domain environment.
  • Your domain structure is organized in a hierarchical domain topology, with a forest root domain and with child domains.
  • Your user account is a member of a new built-in security group that is included in Windows Server 2003. For example, your account is a member of one or more of the following built-in security groups:
    • Network Configuration Operators
    • Performance Log Users
    • Performance Monitor Users
    • Remote Desktop Users
    • Terminal Server License Servers
    • Windows Authorization Access Group
Exchange Server tries to match the security identifiers (SIDs) of the groups that you are a member of with existing groups in the Active Directory directory service. However, built-in group membership should be exempt from this process.

Exchange Server uses a function call to determine whether a SID matches a known built-in group that is stored in the Exchange store built-in groups array. However, the array does not include the new built-in groups that were introduced in Windows Server 2003.

Consider the following scenario:
  • You are a member of a new Windows Server 2003-specific built-in security group.
  • There is a hierarchical domain topology.
In this scenario, Exchange Server finds more than one match to the built-in group SID. Therefore, Exchange Server considers your alias ambiguous. Both the parent domain and the child domain contain several of the same built-in security groups.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Exchange Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are two versions of this hotfix for Exchange Server 2003. The hotfix for Exchange 2003 without Service Pack 1 (SP1) installed has no prerequisites. However, you cannot install the pre-SP1 hotfix on a computer that is running Exchange 2003 with Service Pack 1. There is also a post-Exchange 2003 SP1 hotfix. To install the post-Exchange 2003 SP1 hotfix, you must be running Exchange 2003 with Service Pack 1. For more information about how to obtain Exchange Server 2003 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, Exchange-related services are automatically restarted during the installation process.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

Hotfix for Exchange Server 2003 without Service Pack 1 installed
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   15-Sep-2004  18:36  6.5.6981.0        253,952  Exsmtp.dll       
   15-Sep-2004  01:46  6.5.6981.0         49,664  Mdbevent.dll     
   15-Sep-2004  02:15  6.5.6981.0      3,208,704  Mdbmsg.dll       
   15-Sep-2004  01:47  6.5.6981.0         24,064  Mdbrole.dll      
   15-Sep-2004  18:39  6.5.6981.0         13,312  Mdbtask.dll      
   15-Sep-2004  18:38  6.5.6981.0      5,047,296  Store.exe   
Hotfix for Exchange Server 2003 with Service Pack 1 installed
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Sep-2004  20:32  6.5.7232.35     3,230,720  Mdbmsg.dll       
   16-Sep-2004  20:42  6.5.7232.35     5,132,800  Store.exe  

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Status

Exchange 2000 Server hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

The hotfix has the following prerequisites:
  • You must be running Exchange 2000 Server Service Pack 3. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    301378� How to obtain the latest Exchange 2000 Server service pack
  • You must have the Exchange 2000 Server post-Service Pack 3 update rollup installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    870540� Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 Update Rollup

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, Exchange-related services are automatically restarted during the installation process.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
    Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Sep-2004  04:47  6.0.6617.6      2,310,144  Mdbmsg.dll       
   12-Sep-2004  05:02  6.0.6617.6      4,685,824  Store.exe  

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More information

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Exchange Server 2003 Service Pack 2.

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Keywords: kbautohotfix, kbhotfixserver, kbexchange2003presp1fix, kbexchange2003presp2fix, kbexchange2000presp4fix, kbfix, kbbug, kbqfe, KB870585

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Article Info
Article ID : 870585
Revision : 9
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 291