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A new logical unit number is not detected when a logical unit number is removed from a storage device on a SCSI disk array


View products that this article applies to.

Symptoms

When a logical unit number (LUN) is removed from a storage device on a SCSI disk array in Microsoft Windows Server 2003 or in Microsoft Windows 2000 Server, and a new LUN is available immediately, the new LUN is not detected by the storage device.

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Cause

When a Fibre Channel cable is pulled between the host and the switch, some I/O requests are delayed. Because the I/O requests are delayed, the device objects that belong to the storage device are not processed correctly. Some third-party multipath failover drivers prevent the SCSI port driver from removing the device objects because there are still outstanding I/O requests that have not been completed.

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Resolution

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit editions
Date         Time   Version            Size    File name      Platform
----------------------------------------------------------------------
06-Jul-2004  23:56  5.2.3790.186      127,488  Scsiport.sys   x86
Windows Server 2003, 64-Bit Enterprise Edition
Date         Time   Version            Size    File name      Platform
----------------------------------------------------------------------
06-Jul-2004  22:38  5.2.3790.186      292,352  Scsiport.sys   IA-64

Windows 2000 Server hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
13-Aug-2004  17:30  5.0.2195.6968      74,224  Scsiport.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbqfe, kbhotfixserver, kbwin2000sp5fix, kbhowtomaster, kb3rdparty, kbbug, kbfix, kbwinserv2003presp1fix, kbautohotfix, KB867818

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Article Info
Article ID : 867818
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 377