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Files in the Single Instance Storage (SIS) Common Store folder are no longer valid after you restore a Remote Installation Services (RIS) volume from backup in Windows Server 2003 and in Windows 2000


View products that this article applies to.

Symptoms

You back up a Remote Installation Services (RIS) volume in Microsoft Windows 2000 or in Microsoft Windows Server 2003. The RIS volume that you back up contains the Single Instance Storage (SIS) Common Store folder. When you use Windows Backup or a third-party backup program to restore the RIS volume from backup, some files in the SIS Common Store folder are no longer valid. For example, the size of some files is changed to 0 bytes. Links to the files are broken.

Additionally, when you try to install a RIS image from a Pre-Boot eXecution Environment (PXE)-enabled client, you receive error messages. The following is an example of one of the error messages that you may receive:
TFTP.
TFTP. Failed. e not found

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Cause

This problem occurs if SIS stores incorrect pointers during the restore operation.

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Resolution

Install this hotfix on the destination computer before you restore the RIS volume to that destination computer. You do not have to install this hotfix on the source computer before you back up the RIS volume on that source computer.

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit edition

  Date         Time   Version       Size    File name
  -----------------------------------------------------
  31-Jul-2004  01:05  5.2.3790.196  78,336  Grovel.exe       
  02-Aug-2004  17:02  5.2.3790.196  16,384  Sisbkup.dll      
  31-Jul-2004  01:05  5.2.3790.196  66,048  Sis.sys

Windows Server 2003, 64-bit edition

  Date         Time   Version       Size     File name     Platform
  -----------------------------------------------------------------
  31-Jul-2004  01:07  5.2.3790.196  220,672  Grovel.exe    IA-64
  31-Jul-2004  01:07  5.2.3790.196  210,944  Sis.sys
  02-Aug-2004  16:52  5.2.3790.196   46,080  Sisbkup.dll   IA-64
  02-Aug-2004  17:02  5.2.3790.196   16,384  Wsisbkup.dll  x86

Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows 2000 Service Pack 4 (SP4).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version        Size    File name
  ------------------------------------------------------
  23-Jul-2004  19:28  5.0.2195.6960  15,632  Sisbkup.dll      
  21-Jul-2004  23:51  5.0.2195.6960  89,360  Grovel.exe       
  21-Jul-2004  23:50  5.0.2195.6960  65,072  Sis.sys 

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Workaround

To work around this problem, rename the Sisbkupd.dll file before you start the backup operation to back up the RIS volume. For example, rename the Sisbkupd.dll file to Sisbkupd.dll_old.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies To" section.

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More information

For additional information about how to restore a RIS volume that is managed by SIS, click the following article number to view the article in the Microsoft Knowledge Base:
263027 How to restore a volume that is managed by Single Instance Storage
For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows hotfix packages
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbwinserv2003presp1fix, kbwin2000presp5fix, kbfix, kbbug, KB867765

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Article Info
Article ID : 867765
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 414