Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"DRIVER_IRQL_NOT_LESS_OR_EQUAL (0xD1)" Stop error occurs in Windows Server 2003 when you remove a USB device


View products that this article applies to.

Symptoms

A Microsoft Windows Server 2003-based computer may stop responding, and you may receive a "DRIVER_IRQL_NOT_LESS_OR_EQUAL (0xD1)" Stop error. This error may occur only when you repeatedly perform a surprise removal of a USB device.

↑ Back to the top


Cause

This problem occurs because of a code defect in the USB controller port driver (Usbport.sys).

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit editions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Jun-2004  23:32  5.2.3790.161        6,656  Hccoin.dll       
   11-Apr-2004  07:39  5.2.3790.161       28,928  Usbccgp.sys
   11-Apr-2004  07:39  5.2.3790.161       19,968  Usbehci.sys
   11-Apr-2004  07:39  5.2.3790.161       54,784  Usbhub.sys
   11-Apr-2004  07:39  5.2.3790.161       16,896  Usbohci.sys
   22-Jun-2004  22:29  5.2.3790.186      139,008  Usbport.sys
   11-Apr-2004  07:39  5.2.3790.161       20,096  Usbuhci.sys
 
Windows Server 2003, 64-Bit Edition


   Date         Time   Version            Size    File name    Platform
   ----------------------------------------------------------------------------
   22-Jun-2004  23:22  5.2.3790.161       12,800  Hccoin.dll       IA-64
   11-Apr-2004  07:32  5.2.3790.161      114,560  Usbccgp.sys
   11-Apr-2004  07:32  5.2.3790.161       61,312  Usbehci.sys
   11-Apr-2004  07:32  5.2.3790.161      183,296  Usbhub.sys
   11-Apr-2004  07:32  5.2.3790.161       51,712  Usbohci.sys
   22-Jun-2004  22:29  5.2.3790.186      430,976  Usbport.sys
   11-Apr-2004  07:32  5.2.3790.161       64,896  Usbuhci.sys
   22-Jun-2004  23:32  5.2.3790.161        6,656  Whccoin.dll      x86


↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kberrmsg, kbbug, kbfix, kbwinserv2003presp1fix, kbqfe, kbhotfixserver, kbautohotfix, KB867754

↑ Back to the top

Article Info
Article ID : 867754
Revision : 10
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 385