Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Logical Disk Manager may stop responding or may report an error when you replace a dynamic disk in Windows Server 2003 while the computer is running


View products that this article applies to.

Symptoms

When you swap a dynamic disk on your Microsoft Windows Server 2003-based computer while the computer is running, Logical Disk Manager may stop responding (hang) or may report an error. In this scenario, the following events appear in Event Viewer:

Event Log Description:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7034
Date: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
The Logical Disk Manager Administrative Service service terminated unexpectedly. It has done this 2 time(s).

For more information, see Help and Support Center at http://support.microsoft.com.

Event Type: Error
Event Source: Virtual Disk Service
Event Category: None
Event ID: 10
Date: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
Unexpected provider failure. Restarting the service may fix the problem. Error code: 80042420@02000034

For more information, see Help and Support Center at http://support.microsoft.com.

↑ Back to the top


Cause

After you remove the disk that you want to swap out, an access violation occurs in the Dmadmin service when Logical Disk Manager rescans the disk.

Note Logical Disk Manager performs this rescan to change the disk's state to Missing after you remove it.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 837814.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 32-bit editions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   12-Jun-2004  00:02  5.2.3790.183      340,480  Dmconfig.dll      
Windows Server 2003, 64-bit edition
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   11-Jun-2004  23:57  5.2.3790.183      946,176  Dmconfig.dll     IA-64 

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB867699, kbhotfixserver, kbqfe, kbwinserv2003presp1fix, kbfix, kbbug, kbautohotfix

↑ Back to the top

Article Info
Article ID : 867699
Revision : 7
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 343