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The rules on public folders may not be applied in Exchange Server 2003


View products that this article applies to.

Symptoms

After you configure rules on a public folder, the rules may not be applied as expected in Microsoft Exchange Server 2003.

Typically, this problem occurs in a scenario that is similar to the following:
  • E-mail is sent from Lotus Notes over a Lotus Notes Connector to a Microsoft Exchange 5.5 organization. The recipient address is an X.400 custom recipient.
  • The Exchange 5.5 server sends the e-mail over an X.400 connector to an Exchange 2003 organization.
  • In the Exchange 2003 organization, the X.400 custom recipient address is changed to a distribution list that contains three public folders.
  • The e-mail is delivered to the three public folders.
  • A rule that is configured on the public folders is expected to forward the e-mail to three different mailboxes. However, the rule is only applied to the oldest folder; the rule is not applied to the other two folders.

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Cause

This problem occurs if the PR_TO_ME, PR_RECIP_ME, and PR_CC_ME properties are removed from the e-mail the first time that the e-mail is forwarded. After the PR_TO_ME, PR_RECIP_ME, and PR_CC_ME properties are removed from the e-mail, the next time the e-mail is forwarded, the CopyMsg function is returned with warnings. The warnings that are returned with the CopyMsg function cause the rule engine to calculate that the rule cannot be applied. Therefore, the rule engine does not apply the rule to the public folders.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
 Date         Time   Version            Size    File name
--------------------------------------------------------------
27-Jun-2004  04:18  6.5.6980.94        20,480  Exhotfix.dll     
02-Jul-2004  02:24  6.5.7232.9      5,130,240  Store.exe        
27-Jun-2004  04:18  6.5.6980.94        20,480  Exhotfix.dll

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Exchange Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB867571, kbbug, kbfix, kbexchange2003presp2fix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 867571
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 321