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Error message when you set up Intercompany accounts in Microsoft Dynamics GP: "Account XXX does not exist"


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SYMPTOMS

When you set up Intercompany accounts in the Intercompany Setup window and select an account for the originating company or for the destination company in Microsoft Dynamics GP, you receive the following error message:

Account XXX does not exist. Enter an existing posting or posting allocation account or select one from the lookup window.

The account may exist in both companies. However, in the account lookup window, some accounts have hyphens and some accounts do not. If you select the accounts that do not have hyphens, this error message occurs.

CAUSE

This problem may occur because the account number string in the ACTNUMST field in the Account Index Master table (GL00105) is missing the hyphens for those accounts. This may be because that you have increased the length of one of the account format segments in General Ledger. Then, Microsoft Dynamics GP will add a space or blank character to any existing accounts to fill up the rest of that segment. In this scenario, to find an account, you have to key it in by using a space to fill up the increased segment and exclude the hyphens.

RESOLUTION

To resolve this problem, re-create the GL00105 table. To do this, follow these steps:
1. Delete the GL00105 table. To do this, follow these steps:
a.

Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using.

 

Method 1: For SQL Server Desktop Engine

If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start , point to All Programs , point to Microsoft Administrator Console , and then click Support Administrator Console .

Method 2: For SQL Server 2000

If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start , point to All Programs , point to Microsoft SQL Server , and then click Query Analyzer .

Method 3: For SQL Server 2005

If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start , point to All Programs , point to Microsoft SQL Server 2005 , and then click SQL Server Management Studio .

Method 4: For SQL Server 2008

If you are using SQL Server 2008, start SQL Server Management Studio. To do this, click Start , point to All Programs , point to Microsoft SQL Server 2008 , and then click SQL Server Management Studio .
b. Click New Query .
c. Select the company database from the drop-down list.
d. Run the following script in the query:
Delete GL00105 
2. Run the Check Links process to re-create the GL00105 table. To do this, follow these steps:
a.

In Microsoft Dynamics GP, open the Check Links window:

• For Microsoft Dynamics GP 10.0, point to Maintenance on the Microsoft Dynamics GP menu, and then click Check Links .
• For Microsoft Dynamics GP 9.0, point to Maintenance on the File menu, and then click Check Links .



     
b. In the Series field, click to select Financial .
c. In the Logical Tables list, click to select Account Master , and then click Insert .
d. Click OK .
e. In the Report Destination window, click to select the Screen check box or the Printer check box, and then click OK .

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Techknowledge Document ID: 4039

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Keywords: kb, kbnosurvey, kbtshoot, kbprb, kbExprtiseAdvanced, kbMBSMigrate, kbMBSPartner, BemisKB863715

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Article Info
Article ID : 863715
Revision : 1
Created on : 3/9/2017
Published on : 3/9/2017
Exists online : False
Views : 283