SYMPTOMS
When you startIntegration Manager, you may receive the following error:
Internal error in ADODB.connection. Number 3706. Provider cannot be found. It may not be properly installed.
CAUSE
Typically this error is caused by a damaged/invalid key in the InstallShield directory which is C:\Program Files\InstallShield Installation Information.
RESOLUTION
1. Remove all versions of Integration ManagerusingAdd/Remove Programs.
2. Remove the HKEY_LOCAL_MACHINE\Software\Microsoft\Great Plains\Integration Manager\ key in the registry. Also, remove the HKEY_CURRENT_USER\Software\Microsoft\Great Plains\Integration Manager\ key in the registry.
3. Make sure the following directories are gone:
%IM% <-where ever IM was installed to previously
%Program Files%\IM\
%Program Files%\%Common Files%\CBOM\
4. Make sure the following files are not in the %System% directory.
Cbomlibx.dll
Cbom.dll
Cbom.tlb
Ttgcomnx.dll
Ttgscrx.dll
Ttgvbolex.dll
Ttgvbole.dll
The quickest way is to search for Ttg*.* in the %System% and remove them and then to search from Cb*.dll and remove them. Makesure that they are indeed one of these above files before you removethem.
This should completely remove any references to Integration Manager on the machine.
5. Install the latest version of MDAC, which is 2.8, from
http://msdn.microsoft.com/data/Default.aspx. To check your current MDAC version, go to HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess version.
6. Create a Backup Folder and cut the contents from C:\Program Files\InstallShield Installation Information into the backup folder you created.
7. Re-install release 7.5 Service Pack 3of Integration Manager then apply Service Pack 4. Click
https://mbs.microsoft.com/fileexchange/?fileID=59682871-a5e0-4660-a36f-4be0d07aecfc to download Service Pack 3. Click
https://mbs.microsoft.com/downloads/customer/IM75sp4.zip to download Service Pack 4.
This article was TechKnowledge Document ID:34645
When you startIntegration Manager, you may receive the following error:
Internal error in ADODB.connection. Number 3706. Provider cannot be found. It may not be properly installed.
CAUSE
Typically this error is caused by a damaged/invalid key in the InstallShield directory which is C:\Program Files\InstallShield Installation Information.
RESOLUTION
1. Remove all versions of Integration ManagerusingAdd/Remove Programs.
2. Remove the HKEY_LOCAL_MACHINE\Software\Microsoft\Great Plains\Integration Manager\ key in the registry. Also, remove the HKEY_CURRENT_USER\Software\Microsoft\Great Plains\Integration Manager\ key in the registry.
3. Make sure the following directories are gone:
%IM% <-where ever IM was installed to previously
%Program Files%\IM\
%Program Files%\%Common Files%\CBOM\
4. Make sure the following files are not in the %System% directory.
Cbomlibx.dll
Cbom.dll
Cbom.tlb
Ttgcomnx.dll
Ttgscrx.dll
Ttgvbolex.dll
Ttgvbole.dll
The quickest way is to search for Ttg*.* in the %System% and remove them and then to search from Cb*.dll and remove them. Makesure that they are indeed one of these above files before you removethem.
This should completely remove any references to Integration Manager on the machine.
5. Install the latest version of MDAC, which is 2.8, from
http://msdn.microsoft.com/data/Default.aspx. To check your current MDAC version, go to HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess version.
6. Create a Backup Folder and cut the contents from C:\Program Files\InstallShield Installation Information into the backup folder you created.
7. Re-install release 7.5 Service Pack 3of Integration Manager then apply Service Pack 4. Click
https://mbs.microsoft.com/fileexchange/?fileID=59682871-a5e0-4660-a36f-4be0d07aecfc to download Service Pack 3. Click
https://mbs.microsoft.com/downloads/customer/IM75sp4.zip to download Service Pack 4.
This article was TechKnowledge Document ID:34645