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Error message when you try to install Microsoft Dynamics CRM: "Action Microsoft.Crm.Config.Common.InstallDatabaseAction failed. Logon failure: unknown user name or bad password"


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Symptoms

Microsoft Dynamics CRM 4.0 and Microsoft Dynamics 2011

In the Applying Configuration window of the Microsoft Dynamics CRM Configuration Wizard, you receive the following error message:
Action Microsoft.Crm.Config.Common.InstallDatabaseAction failed. Logon failure: unknown user name or bad password
Or, in the Environment Diagnostics Wizard, you receive the following error message:
Error| Check SqlInstanceNameValidator : Failure: The instance name must be the same as computer name.

Microsoft Dynamics CRM 3.0 and earlier versions

When you try to install Microsoft Dynamics CRM 3.0, Microsoft CRM 1.2, or Microsoft Business Solutions - CRM 1.0, you receive the following error message:
The instance name must be the same as the computer name.
In Microsoft Dynamics CRM 3.0, you receive this error message in the Environment Diagnostic Wizard.

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Cause

This problem occurs if the server that is running Microsoft SQL Server was renamed. The Microsoft Dynamics CRM databases are stored on this server.

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Resolution

Microsoft SQL Server 2005 and Microsoft SQL Server 2008

To resolve this problem, rename the computer that hosts a stand-alone instance of SQL Server. To do this, use one of the following methods.

For a renamed default instance

  1. Run the following procedures against the master database:
    sp_dropserver old_name go sp_addserver new_name, local go
    Note old_name is the old name of the server that is running SQL server. new_name is the actual name of the server that is running SQL server.
  2. Restart the instance of SQL Server.

For a renamed named instance

  1. Run the following procedures:
    sp_dropserver old_name\instancename go sp_addserver new_name\instancename, local go
    Note old_name is the old name of the server that is running SQL server. new_name is the actual name of the server that is running SQL server.
  2. Restart the instance of SQL Server.

Microsoft SQL Server 2000

To resolve this problem, update the SYSSERVERS table to reflect the new server name. To do this, follow these steps:
  1. If Microsoft Dynamics CRM is listed in the Add or Remove Programs item in Control Panel, uninstall Microsoft Dynamics CRM.
  2. On the server that is running SQL Server, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  3. In the Connect to SQL Server dialog box, click the server that is running SQL Server in the SQL Server list, and then click OK.
  4. In the database list, click the master database.
  5. In the Query box, enter the following script.
    sp_addserver <new_server_name>, local go
    Note <new_server_name> is the actual name of the server that is running SQL Server. To find this name, right-click My Computer, click Properties, and then click the Computer Name tab.
  6. Restart the server that is running SQL Server.
  7. Try to install Microsoft Dynamics CRM again.

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More information

To determine whether the server that is running SQL Server was renamed, open SQL Query Analyzer, and then run the following select statement against the master database.
Select @@servername
This statement returns the server name that was used when SQL Server was installed.

If you rename a computer on which you have installed the Microsoft Dynamics CRM client for Microsoft Office Outlook, and the Microsoft Dynamics CRM client for Outlook has offline access, you must rerun the Microsoft Dynamics CRM Configuration Wizard. Then, you must connect to the existing instance of SQL 2005 Express.

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References

This article was TechKnowledge document 27671.

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Keywords: KB857505, kbsurveynew, kbprb, kbtshoot, kbmbsmigrate

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Article Info
Article ID : 857505
Revision : 7
Created on : 1/27/2011
Published on : 1/27/2011
Exists online : False
Views : 432