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Error message when you run the General Ledger Year-End Closing routine in Microsoft Dynamics GP: “Account assigned to a transaction is missing”


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Symptoms

When you run the Year-End Closing routine in General Ledger in Microsoft Dynamics GP, you receive the following error message:
Account assigned to a transaction is missing.

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Cause

The error occurs if there are transactions in the General Ledger Open table (GL20000) that have an account index value that is not present in the Account Master Table (GL00100).

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Resolution

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

To resolve the error, follow one of these methods:



Method 1: Use a query tool to locate the transaction

  1. Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using.

    Method 1: For SQL Server Desktop Engine

    If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start, point to All Programs, point to Microsoft Administrator Console, and then click Support Administrator Console.

    Method 2: For SQL Server 2000

    If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.

    Method 3: For SQL Server 2005

    If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.

    Method 4: For SQL Server 2008

    If you are using SQL Server 2008, start SQL Management Studio. to do this, click Start, point to All Programs, point to Microsoft SQL Server 2008, and then click SQL Server Management Studio.
  2. Run the following statement against the company database.

    select JRNENTRY, ACTINDX from GL20000 where ACTINDX not in (select ACTINDX from GL00100) 

    This script lists the journal entries that have an ACTINDX value that is not present in the GL00100 (Account Master) table.
  3. Note the journal entry (JRNENTRY) numbers that are returned. Then, remove these entries.

    For information about technical support for removing journal entries, visit the following Microsoft Web site:

Method 2: Use Report Writer to identify the transaction

To use Report Writer to identify the transaction, follow these steps.

Step 1: Create the report

  1. Start Report Writer. To do this, follow the steps for your version of the program.
    • Microsoft Dynamics GP 10.0

      On the Microsoft Dynamics GP menu, point to Tools, point to Customize, and then click Report Writer.
    • Microsoft Dynamics GP 9.0

      On the Tools menu, point to Customize, and then click Report Writer.

  2. In the Product list, click Microsoft Dynamics GP. Then, click OK.

  3. Click Reports, and then click New.
  4. In the Report Definition window, specify the following settings:
    • Report Name: YTD Transaction Dump
    • Series: Financial
    • Main Table: Year-to-Date Transaction Open
    • Using Key:: GL_YTD_TRX_OPEN_Key1
    • In the Format Options area, click to clear the Skip Blank Records check box.

  5. In the Report Definition window, click Tables.
  6. In the Tables list, click Year-to-Date Transaction Open. Then, click New.
  7. Double-click Account Master.
  8. Click Close to close the Report Table Relationships window.
  9. In the Report Definition window, click Sort.
  10. In the Report Table list, click Account Master.
  11. In the Table Fields list, click Account Number, click Insert, and then click OK.

Step 2: Add the new fields to the report

  1. Click Layout.
  2. In the Toolbox window list, click Year-to-Date Transaction Open.
  3. Drag the Account Index field and the Journal Entry field to the Body (B) section of the report.
  4. In the Toolbox window list, click Account Master.
  5. Drag the Account Number field to the Body (B) section of the report.

Step 3: Save and print the report

  1. Close the report layout, and then close the close the Report Definition window. Click Save when you are prompted to save changes.
  2. In the Modified Reports list, click YTD Transaction Dump, and then click Print.



    Note The records that print at the top of the report do not have account numbers assigned to them. Note the journal entry numbers. Then, remove these entries.

    For information about technical support for removing journal entries, visit the following Microsoft Web site:

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Keywords: kbnosurvey, kberrmsg, kbsurveynew, kbexpertisebeginner, kbtshoot, kbprb, kbexpertiseinter, kbmbspartner, kbmbsmigrate, kb

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Article Info
Article ID : 855209
Revision : 1
Created on : 3/3/2017
Published on : 12/29/2014
Exists online : False
Views : 322