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Error message when you try to print a historical Sales Order Processing invoice in Microsoft Dynamics GP: "You must be viewing by Functional or Originating currency to print a document


IMPORTANT

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

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SYMPTOMS

When you try to print a historical Sales Order Processing invoice in Microsoft Dynamics GP or in Microsoft Business Solutions – Great Plains, you receive the following error message:

You must be viewing by Functional or Originating currency to print a document.

This problem occurs if you do not have Multicurrency registered.

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CAUSE

This problem occurs because the VIEWTYPE values that are set for the Sales Document Inquiry window or the RM Transaction Inquiry window are incorrect. This information is stored in the Multicurrency User Preference table (MC40500).

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RESOLUTION

To resolve this problem, update table MC40500. To do this, follow these steps:
1. Follow the appropriate step: • If you are using Microsoft SQL Server 7.0 or Microsoft SQL Server 2000, run the statement in SQL Query Analyzer. To open SQL Query Analyzer, click Start , point to Programs , point to Microsoft SQL Server , and then click Query Analyzer .
• If you are using Microsoft SQL Server Desktop Engine, run the statement in the Support Administrator Console. To open the Support Administrator Console, click Start , point to Programs , point to Microsoft Support Administrator Console , and then click Support Administrator Console .

Note The Support Administrator Console requires a separate installation. If you do not have the program installed, you can install it by using the Microsoft Dynamics GP installation CD.
• If you are using Microsoft SQL Server 2005, run the statement in SQL Server Management Studio. To open SQL Server Management Studio, click Start , point to Programs , point to Microsoft SQL Server 2005 , and then click SQL Server Management Studio . To run a script, click New Query .


     
2. Make sure that all users exit Microsoft Dynamics GP or Microsoft Business Solutions – Great Plains.
3. Run the following query against your company database, and then note the value in the DEX_ROW_ID column.
SELECT DEX_ROW_ID, * FROM MC40500 WHERE TRXSOURC IN (SOP_Document_Inquiry, RM_Transaction_Inquiry) 
4. Run the following UPDATE script.
UPDATE MC40500 SET VIEWTYPE = 3 WHERE DEX_ROW_ID = <X> 
Note Replace <X> with the value in the DEX_ROW_ID column that you noted in step 3.
5. Repeat this UPDATE script for all the records that you want to update.

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Keywords: kb, kbnosurvey, kbtshoot, kbprb, kbMBSMigrate, kbMBSPartner, BemisKB854925, kbExpertiseInter

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Article Info
Article ID : 854925
Revision : 1
Created on : 3/9/2017
Published on : 3/9/2017
Exists online : False
Views : 82