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Error message when you perform the Reconcile procedure or the Aging procedure in Receivables Management in Microsoft Dynamics GP: "Unhandled script exception, value of range, exception class script out of range"


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SYMPTOMS

Consider the following scenario. You perform the Reconcile procedure or the Aging procedure in Receivables Management in Microsoft Dynamics GP or in Microsoft Business Solutions - Great Plains. When you do this, you receive the following error message:

Unhandled script exception, value of range, exception class script out of range

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CAUSE

This issue occurs for one of the following reasons:

• The Statement Cycle is missing on the Customer Maintenance Options window.

  • There is a record in an RM table with a blank Customer ID.
  • In the Reconcile Receivables Amounts window, you clicked Current Customer Information , and then you clicked Process .

• In the Receivables Aging Process window, you clicked Process .

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RESOLUTION

To resolve this problem, use one of the following methods.

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

 

Method 1

1. When you receive the error message, note the customer record on which the process stopped.
2. On the Cards menu, point to Sales , and then click Customer .
3. In the Customer ID field, type the customer identifier (ID) of the customer record that you noted in step 1. Click Options .
4. In the Customer Maintenance Options window, click a statement cycle in the Statement Cycle list, and then click OK .

Method 2

Use this method if one of the following conditions is true:

• You followed the steps in Method 1, and then you performed the Reconcile procedure or the Aging procedure again. When you did this, you received the same error message. But, the process stopped on a different customer record.

• You followed the steps in Method 1, and then you performed the Reconcile procedure or the Aging procedure again. When you did this, you received the same error message, and the process stopped on the same customer record.




     
  •  
To use this method, follow these steps:
1. In the Customer Maintenance Options window, determine the customer records that contain a blank statement cycle. To do this, follow these steps:
a. Open SQL Server Management Studio.  To do this, click Start , point to All Programs , point to Microsoft SQL Server 20XX (your version) , and then click SQL Server Management Studio .
b. Run the following statement against the company database.
select * from RM00101 where STMTCYCL = '' 
c. Note the customer IDs from the result of the statement that you ran in step 1b.
2. Assign the statement cycle for the customer records that you noted in step 1c. To do this, follow these steps:
a. On the Cards menu, point to Sales , and then double-click Customer .
b. In the Customer Maintenance window, enter the first customer ID that you noted in step 1c in the Customer ID box, and then click Options .
c. In the Customer Maintenance Options window, make sure that a statement cycle is specified in the Statement Cycle field, and then click OK .
d. Click Save .
e. Repeat steps 2b through 2d for each customer ID that you noted in step 1c.
3. Run the Check Links process. To do this, follow these steps:
a.

Use the appropriate method:

• In Microsoft Dynamics GP 10.0 and higher versions, point to Maintenance on the Microsoft Dynamics GP menu, and then click Check Links .
• In Microsoft Dynamics GP 9.0 or in Microsoft Business Solutions - Great Plains 8.0, point to Maintenance on the File menu, and then click Check Links .


  •  
b. In the Check Links window, click Sales in the Series list, click Receivables Customer Master Files , and then click Insert .
c. Click OK .

Method 3

Use this method if you still receive the error message after you use method 1 and method 2. To use this method, follow these steps:
1.

Determine whether the following tables contain blank records:

• The RM Customer Master table (RM00101)
• The Customer Master Address File table (RM00102)
• The Customer Master Summary table (RM00103)
• The Customer Period Summary table (RM00104)
• The RM Statements E-mail Addresses table (RM00106)


  •  
To do this, follow these steps:
a. Open SQL Server Management Studio.  To do this, click Start , point to All Programs , point to Microsoft SQL Server 20XX (your version), and then click SQL Server Management Studio .
b. Run the following statements against the company database.
select DEX_ROW_ID,* from RM00101 where CUSTNMBR = ''
select DEX_ROW_ID,* from RM00102 where CUSTNMBR = ''
select DEX_ROW_ID,* from RM00103 where CUSTNMBR = ''
select DEX_ROW_ID,* from RM00104 where CUSTNMBR = ''
select DEX_ROW_ID,* from RM00106 where CUSTNMBR = '' 
c. Note the DEX_ROW_ID values from the result of the statements that you ran in step 1b.

Note You will use these DEX_ROW_ID values to delete the blank records in step 2.
2.

Use an SQL query tool to delete the blank records. For more information about how to delete records, contact your Microsoft Dynamics partner. Or, contact technical support for Microsoft Dynamics GP. For information about technical support for Microsoft Dynamics GP, visit the following Microsoft Web site:

http://www.microsoft.com/dynamics/support/default.mspx

3. Run the Check Links process. To do this, follow these steps:
a.

Use the appropriate method:

• In Microsoft Dynamics GP 10.0 and higher versions, point to Maintenance on the Microsoft Dynamics GP menu, and then click Check Links .
• In Microsoft Dynamics GP 9.0 or in Microsoft Business Solutions - Great Plains 8.0, point to Maintenance on the File menu, and then click Check Links .

b. In the Check Links window, click Sales in the Series list, click Receivables Customer Master Files , and then click Insert .
c. Click OK .
4. Perform the Reconcile procedure or the Aging procedure again.

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Keywords: kb, kberrmsg, kbtshoot, kbMBSgp10, kbMBSMigrate, kbMBSPartner, kbFreshness2007, kbprb, kbExpertiseInter, kbnosurvey, BemisKB851191

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Article Info
Article ID : 851191
Revision : 4
Created on : 5/3/2017
Published on : 5/3/2017
Exists online : False
Views : 378