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A workstation may become the master browser instead of a Windows Server 2003-based member server


View products that this article applies to.

Symptoms

A computer that provides a workstation role, such as a computer that is running Microsoft Windows 2000 Professional or Microsoft Windows XP Professional, may become the master browser for the Computer Browser service. This behavior may not be what you want if you want a computer that is a member server to be the master browser.

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Cause

This behavior occurs because workstation computers and member servers have an equal chance to become the master browser during the browser election process. The browser election process determines the master browser for the network segment.

For additional information about the Computer Browser service, click the following article number to view the article in the Microsoft Knowledge Base:
188001 Description of the Microsoft Computer Browser service
Note By default, Windows-based servers that are domain controllers receive preference to become the master browser during a browser election.

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Resolution

To resolve this behavior and to give Windows Server 2003-based member servers preference to become the master browser during a browser election, install the following update.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

   
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2004  02:20  5.2.3790.194      395,264  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194      158,208  Rdbss.sys

Windows Server 2003, 64-Bit Edition


   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-Jul-2004  02:20  5.2.3790.194    1,123,328  Mrxsmb.sys
   20-Jul-2004  02:20  5.2.3790.194      464,896  Rdbss.sys

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

To determine which computer is the master browser, type the following command at a command prompt on your Windows-based server, and then press ENTER:
browstat status

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB843517, kbwinserv2003presp1fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 843517
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 346