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Error messages that you might receive when you try to install the Mailbox Manager component in Exchange Server 5.5


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Summary

This article discusses problems that may occur when you install the Mailbox Manager component in Microsoft Exchange Server 5.5. This article describes the symptoms that you might experience, the problem that causes these symptoms, and the resolution or the workaround for each problem. The symptoms are listed in the following order:

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Introduction

This article discusses problems that may occur when you install the Mailbox Manager component for Exchange Server 5.5. This article contains a resolution or a workaround for each problem.

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More information

You receive a "Setup has failed" error message

When you run the Microsoft Exchange Mailbox Manager Setup program and you click Install or Remove, you may receive the following error message:
Setup has failed. You can run the Setup program at a later time to install the application again.

Cause

You receive this error message because the Microsoft Exchange System Attendant service is stopped.

Resolution

To resolve this problem, start the Microsoft Exchange services, and then run the Mailbox Manager Setup program.

You receive an error message that indicates that the Mbcleanm.dll file cannot be opened

When you run the Mailbox Manager Setup program to install Mailbox Manager on your Exchange Server 5.5 computer, you may receive the following error message:
Could not open the file named c:\winnt\system32\mbcleanm.dll

Cause

This error occurs if the Mbcleanm.dll file is held open by Event Viewer. Mbcleanm.dll is the resource file for Mailbox Manager.

Resolution

To resolve this issue, close Event Viewer, and then run the Mailbox Manager Setup program again.

You receive an "Insufficient network drive letters" error message

You cannot successfully install Mailbox Manager, and you receive the following error message:
Insufficient network drive letters available! Please free two drive letters and try again.

Cause

This problem may occur when the Exchsrvr\Add-ins folder is not shared or when the permissions that you must have to install Mailbox Manager have been removed.

Resolution

To resolve this problem, share the Add-ins folder. To do this, follow these steps:
  1. Locate the Exchsrvr\Add-ins folder in Microsoft Windows Explorer.
  2. Right-click the folder, and then click Sharing.
  3. In the Add-ins Properties dialog box, click Share As. The folder name appears in the Share name field, and "Access to EDK objects" appears in the Comment field.
  4. Click Permissions. In the Access through share permissions dialog box, verify that the following permissions are set:
    • All users must have Read permission.
    • The Exchange service account must have Full Control permission.
    • Administrators must have Full Control permission.
  5. Click OK.
  6. Click Apply, and then click OK.
  7. Run the Mailbox Manager Setup program.

You receive an "Unable to install mailbox agent" error message, and event 287 is logged

When you install Mailbox Manager on a server that has been restored or on a server that has been reinstalled, you may receive the following error message:
Unable to install mailbox agent, 80004005
Additionally, the following event is logged in the application log in Event Viewer:

Event Type: Error
Event Source: MSExchangeDSImp
Event Category: None
Event ID: 287
Date: Date
Time: Tine
User: N/A
Computer: EX05
Description: Unable to create object MBClean99:Alpha because it already exists.

The Mailbox Manager object appears in the Add-Ins container in the Microsoft Exchange Server Administrator program, but the Exchange Server Mailbox Manager service does not appear when you double-click Services in Control Panel.

Cause

This problem occurs because an Exchange computer that has been reinstalled uses a backup Dir.edb file to retain the previous configuration of the directory. The Mailbox Manager object is still present in this Dir.edb file. If you run the Setup program to remove Mailbox Manager, the Setup program does not remove these directory objects.

Resolution

To resolve this problem, follow these steps:
  1. Start the Administrator program.
  2. Click the Add-Ins container.
  3. Delete the following items:
    • Mailbox Manager Object
    • Extension for Microsoft Exchange Mailbox Manager for i386
    • Extension for Microsoft Exchange Mailbox Manager for Alpha
  4. Run the Mailbox Manager Setup program again.

You receive an "Unable to install mailbox agent" error message, and event 2037 is logged

If you install Mailbox Manager, you may receive the following error message:
Unable to Install Mailbox Agent (80004005)
Additionally, the following event is logged in the application log in Event Viewer:

Event ID: 2037
Source: MSExchangeSA
Category: General
Type: Error
Description: The file version of "\address\GWISE\i386\gwxpxgen.dll" on the local server is not current. Unable to locate a correct version on any server in the site.

Cause

This problem occurs when the proxy address generator does not correctly generate a Novell GroupWise address for the mailbox agent.

Workaround

To work around this problem, follow these steps to install Mailbox Manager:
  1. Start the Administrator program.
  2. Expand the Site object, click Configuration, click Site Addressing, and then click Properties.
  3. Click the Site Addressing tab.
  4. Click to clear the GroupWise e-mail address check box, and then click Apply.
  5. In the Remove this address from all existing recipients dialog box, click No.
  6. Run the Mailbox Manager Setup program.
  7. Expand the Site object, click Configuration, click Site Addressing, and then click Properties.
  8. Click to select the GroupWise e-mail address check box, and then click Apply.
  9. In the Add this address to all existing recipients dialog box, click No.

You receive an "mbclean99 could not be loaded" error message

When you start Mailbox Manager from the add-ins container of the Administrator program, you may receive the following error message:
"mbclean99" could not be loaded. 0xc002007e

Cause

This problem may occur if the Administrator program tries to load the Wldap32.dll file and the Mfc42.dll file from a shared folder on the network by using a Universal Naming Convention (UNC) format. If the share is inaccessible, this problem occurs.

Resolution

To resolve this problem, make sure that the shared folder path that contains the Wldap32.dll file and the Mfc42.dll file is available to the computer that you are running the Administrator program on. You may also want to view the application log in Event Viewer to see if it provides additional Universal Naming Convention (UNC) troubleshooting information.

Note You cannot resolve this problem by removing and then reinstalling Exchange.

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Keywords: KB843495, kbinfo

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Article Info
Article ID : 843495
Revision : 6
Created on : 2/6/2007
Published on : 2/6/2007
Exists online : False
Views : 329