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Non-interactive At.exe tasks do not run in Windows Server 2003


View products that this article applies to.

Symptoms

After you use the AT tool (At.exe) to schedule a task, the task may not run as you expect. If you view the task with the Scheduled Tasks tool, you may see the following error status in the Status column of the Scheduled Tasks folder:
0x80
Note To start the Scheduled Tasks tool, click Start, point to All Programs, point to Accessories, point to System Tools, and then click Scheduled Tasks

Additionally, the Schedlgu.txt log file may contain an entry that is similar to the following entry:
"At2.job" (test.cmd)
Finished date and time
Result: The task completed with an exit code of (80).
Note To view the Schedlgu.txt log file, follow these steps:
  1. Click Start, point to All Programs, point to Accessories, point to System Tools, and then click Scheduled Tasks.
  2. On the Scheduled Tasks menu, click Advanced, and then click View Log.
This symptom may occur when all the following conditions are true:
  • The task is configured not to interact with the desktop. When you use the AT tool to schedule a non-interactive task, the non-interactive task does not use the interactive parameter.
  • The AT Service account is configured to log on with a user account instead of with the System account.

    Note To view the AT Service account, follow these steps:
    1. Click Start, point to All Programs, point to Accessories, point to System Tools, and then click Scheduled Tasks.
    2. On the Scheduled Tasks menu, click Advanced, and then click AT Service Account.
  • You connect to the computer with a Terminal Service session. Additionally, the Terminal Service session is logged on as the same user account that is configured for the AT service.

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Cause

This problem occurs because the following conditions are true:
  • The AT service tries to run non-interactive tasks in a specific context.
  • The specific context is that of the user account session.
  • The user account session is connected to the computer that is using Terminal Services.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 64-bit

   Date        Time   Version       Size     File name      Platform
   -----------------------------------------------------------------
   06-Jul-2004 21:18  5.2.3790.186  539,648  Schedsvc.dll   IA-64
   06-Jul-2004 21:13  5.2.3790.186  180,224  Wschedsvc.dll  x86

Windows Server 2003

   Date         Time   Version       Size     File name
   -------------------------------------------------------
   07-Jul-2004  00:13  5.2.3790.186  180,224  Schedsvc.dll

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Workaround

To work around this problem, do not log on to a Terminal Service session with the same user account that is configured for the Task Scheduler service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbbug, kbfix, kbwinserv2003presp1fix, KB843280

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Article Info
Article ID : 843280
Revision : 11
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 621