Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The computer may stop responding and CPU utilization for Internet Explorer may remain high for a long time when you view a Web page


View products that this article applies to.

Symptoms

When you view a Web page in Microsoft Internet Explorer 6 Service Pack 1 that uses absolute positioning together with dynamic HTML (DHTML) element behaviors, you may notice that the memory for the Iexplore.exe process increases at a fast rate until the computer stops responding (hangs) and CPU utilization for Internet Explorer may remain high for a long time.

↑ Back to the top


Cause

This problem occurs when Internet Explorer displays absolute positioned elements on a Web page and processes a DTHML element behavior on the <BODY> HTML tag.

↑ Back to the top


Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Internet Explorer 6.0 SP1

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces a previous hotfix. However, information about that hotfix was never published in a Microsoft Knowledge Base article. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Jun-2004  00:01  6.0.2800.1449   2,692,096  Mshtml.dll   

Installation information

To turn on this hotfix, follow these steps:
  1. Quit Internet Explorer.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate, and then click the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main
  4. Right-click the Main entry, point to New, and then click Key.
  5. Type FeatureControl, and then press ENTER.
  6. Right-click the FeatureControl entry, point to New, and then click Key.
  7. Type KB843268_Performance_Issue, and then press ENTER.
  8. Right-click the KB843268_Performance_Issue entry, point to New, and then click DWORD Value.
  9. Type Iexplore.exe, and then press ENTER.
  10. Right-click Iexplore.exe, and then click Modify.
  11. In the Value data box, type 00000001, and then click OK.
  12. Close Registry Editor.

↑ Back to the top


Workaround

If you can make changes to the Web page, you may be able to work around this problem by changing the Web page so that it does not use absolute positioning for the <BODY> HTML tag.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

↑ Back to the top


Keywords: KB843268, kbie600presp2fix, kbie600sp2fix, kbqfe, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 843268
Revision : 11
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 441