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A Windows Server 2003-based computer may stop responding when it is resumed from standby and events 1030 and 1058 are logged in the application log of a domain controller


View products that this article applies to.

Symptoms

When you resume a Windows Server 2003-based computer from standby, the computer may stop responding. You may also see the "Applying Personal Settings" message box for up to an hour before the desktop appears.

Typically, when you resume a Windows Server 2003-based computer from standby, the computer is locked. Therefore, you must log on to the computer before you can access the desktop. However, when this problem occurs, the computer is not locked, and the Windows Server 2003 logon screen does not appear.

Additionally, the following event messages may be logged in the application event log on the domain controller after you restart the Windows Server 2003-based computer:
Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1058
Description: Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=com. The file must be present at the location <\\domain\sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (Access is denied. ). Group Policy processing aborted. For more information, see Help and Support Center at http://support.microsoft.com.
or
Description: Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=com. The file must be present at the location <\\domain\sysvol\domain\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (The network path was not found. ).

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1030
Description: Windows cannot query for the list of Group Policy objects. A message that describes the reason for this was previously logged by the policy engine. For more information, see Help and Support Center at http://support.microsoft.com.
When you turn on user environment (Userenv) logging, domain Distributed File System (DFS) services may not work after the computer resumes from standby. Additionally, you may receive messages that resemble the following messages in the %SystemRoot%\Debug\UserMode\Userenv.log file.

Note For information about how to turn on Userenv logging, see the Microsoft Knowledge Base article that is referenced in the "References" section.
USERENV(1d8.a84) 21:52:58:718 EvaluateDeferredGPOs: Searching for GPOs in cn=policies,cn=system,DC=domain,DC=local
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Searching <CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=domain,DC=local>
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Machine has access to this GPO.
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: GPO passes the filter check.
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Found functionality version of: 2
USERENV(1d8.a84) 21:52:58:718 ProcessGPO: Found file system path of: <\\domain.local\sysvol\domain.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}>
USERENV(1d8.a84) 21:52:58:734 ProcessGPO: Couldn't find the group policy template file <\\domain.local\sysvol\domain.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini>, error = 0x5.

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Cause

This problem may occur if the Winlogon process tries to process group policies before other components are running. The service pack that this article describes adds logic to improve the default behavior of the Winlogon process and of the workstation services.

However, there are several other scenarios that may cause this problem. Make sure that the following components are started and that they are configured correctly before you apply this service pack:
  • Netlogon and DFS services are started.
  • Domain controllers have the read and apply rights to the Domain Controllers Policy.
  • NTFS file system permissions and share permissions are set correctly on the Sysvol share.
  • DNS entries are correct for the domain controllers.

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Resolution

To resolve this problem, please see the "Service pack information" section that immediately follows. To temporarily work around this problem, please see the "Workaround" section later in this "Resolution" section.

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003
Note After you have installed this service pack, please return to this article to complete the procedure that is outlined in the "Registry information" section that immediately follows.

Registry information

Note Follow these steps in Windows Server 2003.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
To have us complete the procedure for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. In the File Download dialog box, click Run and then follow the steps in the Fix it Wizard.


Fix this problem
Microsoft Fix it 50615

Notes
  • Please�install the service pack in the "Service pack information" section first before you run the package.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

After you have applied this service pack, follow these steps:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. In Registry Editor, locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  3. If the WaitForNetwork entry is missing, you must add the entry. To do this, follow these steps:
    1. Right-click the Winlogon subkey, click New, and then click Dword Value.
    2. In the Value name box, type WaitForNetwork.
  4. Right-click WaitForNetwork, and then click Modify.
  5. In the Edit DWORD Value dialog box, in the Value Data box, type 1, and then click OK.
  6. Close Registry Editor.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

Workaround

To temporarily work around this issue, you can run the Dfsutil.exe file that is included in Windows Server 2003 Support Tools. You can install Windows Server 2003 Support Tools in two ways. You can run \\Support\Tolls\Suptools.msi from the Windows Server 2003 CD-ROM. Or, you can extract the support tools directly from the \\Support\Tools\Support.cab file. To run the Dfsutil.exe file, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type dfsutil /PurgeMupCache, and then press ENTER.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
This problem was first corrected in Windows Server 2003 Service Pack 1.

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References

For more information about how to enable user environment logging, click the following article number to view the article in the Microsoft Knowledge Base:
221833� How to enable user environment debug logging in retail builds of Windows

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Keywords: KB842804, kbmsifixme, kbfixme, kbbug, kbprb, kbwinserv2003presp1fix, kbqfe, kbresolve

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Article Info
Article ID : 842804
Revision : 10
Created on : 2/22/2011
Published on : 2/22/2011
Exists online : False
Views : 328